WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 19 months ago

Last modified 16 months ago

#41303 closed defect (bug) (worksforme)

Fatal error: Maximum execution time of 30 seconds exceeded

Reported by: KhalidAl Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Upgrade/Install Keywords:
Focuses: Cc:
PR Number:

Description

Update WordPress
Downloading update from https://wordpress.org/nightly-builds/wordpress-latest.zip…

Unpacking the update…


Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\wordpress-svn\src\wp-admin\includes\class-wp-filesystem-direct.php on line 80
<?php
if ( $data_length !== $bytes_written )
                        return false;

                $this->chmod( $file, $mode );

                return true;

Steps to replicate:

1-Fresh XAMPP installation
2-Install the beta-tester plugin
3-Switch to Bleeding Edge Nightlies
4-Head to update

Change History (4)

#1 @SergeyBiryukov
2 years ago

  • Component changed from General to Upgrade/Install

#2 @ocean90
2 years ago

  • Keywords reporter-feedback added

Hello @KhalidAl, welcome to WordPress Trac!

Thanks for your report. Are you still able to reproduce the issue? This could be caused by a slow download.

#3 @pratikthink
19 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

@ocean90 is right as he says this could be caused by a slow download. tested.. works fine for me

#4 @netweb
16 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.