WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#41413 closed defect (bug) (duplicate)

incorrect esc in wp_nonce_url

Reported by: pbearne Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.4
Component: General Keywords:
Focuses: Cc:

Description

In wp_nonce_url() esc_html() is used to sanitize the output but the output is a URL so esc_url() makes more sense

Attachments (1)

41413.patch (545 bytes) - added by pbearne 3 years ago.

Download all attachments as: .zip

Change History (2)

#1 @ocean90
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20771.

@pbearne
3 years ago

Note: See TracTickets for help on using tickets.