WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#41460 closed enhancement (duplicate)

Provide info on whether a media item is reused

Reported by: mor10 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

When adding a media item (typically image) to a post or page, the author should be notified whether the same media item is in use on a different post or page. This is important because changes to alt text, crops etc in one post may impact the way the image is displayed in another.

This is a common complaint from new users: They change the alt text for an image in one location and then later realize that same alt text changed somewhere else. Or, they remove an image not realizing it is in use somewhere else.

some sort of indicator a la "This media item is currently in use in the following 8 posts" would be useful.

Change History (2)

#1 @swissspidy
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #28663.

Such a feature is only possible with many-to-many relationships for posts. Right now, only one post is stored (in post_parent) and one would have to use something like Posts 2 Posts to make this more or less work.

See also #10657, #14513, #20540.

#2 @SergeyBiryukov
2 years ago

some sort of indicator a la "This media item is currently in use in the following 8 posts" would be useful.

Gratuitous self-promotion: there's a plugin to address that.

Note: See TracTickets for help on using tickets.