WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 10 months ago

Last modified 10 months ago

#41517 closed defect (bug) (worksforme)

Preview Changes results in Schedule button instead of Update fresh install 4.8 with Twenty Seventeen Theme

Reported by: eclath Owned by:
Milestone: Priority: normal
Severity: minor Version: 4.8
Component: Bundled Theme Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Fresh install of 4.8 using Twenty Seventeen Theme with no active plugins. Editing an already published page and clicking Preview Changes activates the "Schedule" button instead of "Update."
This is only a minor irritation, since clicking "Schedule" immediately changes the button back to "Update," but each click does produce a new revision, and even the "schedule" option actually performs the "Update" action.

Before "Preview Changes" Button clicked:

<div id="publishing-action">
<span class="spinner"></span>
		<input name="original_publish" type="hidden" id="original_publish" value="Update">
		<input name="save" type="submit" class="button button-primary button-large" id="publish" value="Update">
</div>

After "Preview Changes" Button clicked :

<div id="publishing-action">
<span class="spinner"></span>
		<input name="original_publish" type="hidden" id="original_publish" value="Update">
		<input name="save" type="submit" class="button button-primary button-large" id="publish" value="Schedule">
</div>

JQMIGRATE: Migrate is installed, version 1.4.1

Using Chrome (incognito mode) Version 59.0.3071.115 (Official Build) (64-bit) on Windows 7 Professional. (Clearing Cache did not change the result)
Tested on PHP 5.6.31, PHP 7.0.21 and 7.1.7
Tried a second clean installation on a test subdomain and DID reproduce the same result. However, upgrading an existing site to 4.8 did NOT reproduce the symptoms.

Change History (7)

#1 @eclath
4 years ago

  • Severity changed from normal to minor

This ticket was mentioned in Slack in #core by markparnell. View the logs.


10 months ago

#3 @poena
10 months ago

  • Component changed from General to Bundled Theme

#4 @poena
10 months ago

Hi @eclath !

I apologize for the late reply. Hopefully the problem that you experienced has already been solved.

I have tested a new installation of WordPress 4.8 and Twenty Seventeen version 1.3 (bundled).
I only tested on PHP Version 5.6.31 and Chrome version 85.0.4183.102, but I was not able to reproduce the problem.

#5 @eclath
10 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Ha ha! I'm impressed that something this old was checked at all, lol.
I had completely forgotten about this issue, and it has been quite some time since I have run into it. I'm sure we can close this ticket, so I'll update it accordingly. :)

#6 @desrosj
10 months ago

  • Milestone Awaiting Review deleted

#7 @SergeyBiryukov
10 months ago

  • Description modified (diff)

Thanks for the follow-up!

Note: See TracTickets for help on using tickets.