WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#41541 closed defect (bug) (invalid)

New HTML and Text widgets not saving content

Reported by: galbaras Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.1
Component: Widgets Keywords:
Focuses: administration Cc:

Description

Existing text widgets can be adjusted, but new text and Custom HTML widgets are not saved, just cleared.

error_log shows the following PHP warnings, which are likely related:

[03-Aug-2017 02:25:31 UTC] PHP Warning: array_merge(): Argument #2 is not an array in /home/ronitbaras/public_html/wp-includes/default-widgets.php on line 117
[03-Aug-2017 02:25:31 UTC] PHP Warning: array_merge(): Argument #1 is not an array in /home/ronitbaras/public_html/wp-includes/default-widgets.php on line 124

The respective code was added in 4.8.1, which makes this even more likely to be the cause.

I've tested with and without setting the title. I've also tested restoring a deleted text widget, and it works OK, so this is probably related to how 4.8.1 creates new widget instances.

Change History (3)

#1 @westonruter
4 years ago

  • Keywords reporter-feedback added

@galbaras Hi, did you see Jetpack 5.2 had a bug related to this? It was fixed in 5.2.1: https://jetpack.com/2017/08/02/jetpack-5-2-1-fixes-a-sidebar-widget-bug/

If you have Jetpack and you upgrade to 5.2.1, does that fix the issue?

#2 @galbaras
4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Yay, that did it! Thank you so much.

#3 @SergeyBiryukov
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.