WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#41556 closed defect (bug) (duplicate)

Can't style text in the Visual editor

Reported by: velarde Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.1
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

Just after this patch now I can't style text i the visual editor.

Can't choose Type of fonts ( H1, H2, etc) and can't change color of the text. The arrow goes down but it does nothing. I tried it in several sites.

Bold and Italic are working correctly.

Change History (4)

#1 follow-up: @melchoyce
2 years ago

  • Summary changed from Can Style text in the Visual editor to Can't style text in the Visual editor

Hi @velarde!

Couple questions to help us narrow this down:

  • What OS and browser are you using?
  • Do you have any errors in your browser's console?
  • Are you using any of the same plugins on all of the sites you tested?

Thanks :)

#2 in reply to: ↑ 1 @velarde
2 years ago

Hello it seems

I may have been hasty. The problem may actually be related to the Bridge theme which I use in most of my sites.
https://themeforest.net/item/bridge-creative-multipurpose-wordpress-theme/7315054?s_rank=1

So it may not really be actually a bug in Wordpress

It's on Safari mac.

i just can't access the styling functions. I click on them and they don't show the dropdown with the options.

Replying to melchoyce:

Hi @velarde!

Couple questions to help us narrow this down:

  • What OS and browser are you using?
  • Do you have any errors in your browser's console?
  • Are you using any of the same plugins on all of the sites you tested?

Thanks :)

#3 @Clorith
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, and thank you for the report.

This was previously reported in #41542, and the root cause in your case would be the Visual Composer plugin bundled with your theme.

I would recommend updating to the latest version of your theme, if no newer versions exist request it off the theme developers that they make updates available to you to resolve the issue.

#4 @SergeyBiryukov
2 years ago

  • Component changed from Editor to TinyMCE
Note: See TracTickets for help on using tickets.