WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 13 years ago

#4157 closed defect (bug) (duplicate)

Missing " in 'Edit this' admin link breaks theme

Reported by: Podz Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

link-template.php
line 296

return '<a href="' . get_option( 'wpurl' ) . '/wp-admin/' . $file . '.php?action=edit&amp;post=' . $post->ID . '>' . $link . '</a>' . $after;

}

needs to be

return '<a href="' . get_option( 'wpurl' ) . '/wp-admin/' . $file . '.php?action=edit&amp;post=' . $post->ID . '">' . $link . '</a>' . $after;

}

There is a missing " in $post->ID . '>'

Change History (2)

#1 @Podz
13 years ago

Actually, check the wpurl too - it's not putting the subdirectory into my blog so I get

http://www.tamba2.org.uk/wp-admin/post.php?action=edit&post=3086

when it should be

http://www.tamba2.org.uk/T2/wp-admin/post.php?action=edit&post=3086

#2 @foolswisdom
13 years ago

  • Milestone 2.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4153.

Note: See TracTickets for help on using tickets.