WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 7 weeks ago

Last modified 6 weeks ago

#41634 closed enhancement (duplicate)

image-edit button icon titles

Reported by: dj_angola Owned by: nrqsnchz
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: tooltips
Focuses: ui, accessibility Cc:
PR Number:

Description

It is great that the Image edit buttons have icons, and that there is screen-reader-text, however non-screen-reader users are left to guess the meaning of the icons.

I propose to add the same screen reader text to the buttons' title attribute

<button type="button" onclick="imageEdit.flip(2, <?php echo "$post_id, '$nonce'"; ?>, this)" class="imgedit-fliph button" title="<?php esc_html_e( 'Flip horizontally' ); ?>">

Attachments (1)

image-edit-icon-titles.patch (4.7 KB) - added by dj_angola 2 years ago.
patch

Download all attachments as: .zip

Change History (15)

#1 @dj_angola
2 years ago

  • Summary changed from media library button icon titles to image-edit button icon titles

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


2 years ago

#3 @afercia
2 years ago

  • Keywords target-size added
  • Milestone changed from Awaiting Review to Future Release
  • Version 4.9 deleted

Discussed during today's accessibility meeting on Slack. Moving to Future Release as something that should be addressed for all the controls that use only icon in the admin. However, rather than re-introducing title attributes that serve a little purpose, a better solution would be using visible text below the icons. Worth also mentioning the new WCAG 2.1 will require the target size to be at least 44 by 22 pixels, with a few exceptions. See https://www.w3.org/TR/WCAG21/#target-size

Last edited 22 months ago by afercia (previous) (diff)

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


22 months ago

#5 @afercia
20 months ago

  • Keywords tooltips added

Update: the target size requirement has been moved to level AAA in the Candidate Recommendation of WCAG 2.1. Some background here: http://www.incobs.de/articles/items/target-size-fate.html

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


15 months ago

#7 @Travel_girl
13 months ago

  • Keywords needs-design added

#8 @afercia
13 months ago

  • Keywords target-size removed

Screenshot for reference: it's about these buttons in the Image editor:

http://cldup.com/BYvaCfG6ri.png

Needs design feedback for either visible labels underneath the buttons or... tooltips!

This ticket was mentioned in Slack in #accessibility by rianrietveld. View the logs.


13 months ago

#10 @karmatosed
5 months ago

  • Keywords needs-design-feedback added; needs-design removed

Just making sure this has feedback keywords over needing a design as that seems right suggestion.

#11 @afercia
4 months ago

Related: #47116.

#12 @joedolson
2 months ago

  • Owner set to nrqsnchz
  • Status changed from new to assigned

#13 @nrqsnchz
7 weeks ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing as a duplicate of #47116. Both tickets are about the same topic and there's been more momentum there.

#14 @desrosj
6 weeks ago

  • Keywords needs-design-feedback removed
  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.