WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#41664 closed defect (bug) (worksforme)

Romanian diacritics are wrong

Reported by: ovidiuav Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.1
Component: I18N Keywords:
Focuses: Cc:

Description

Hi guys,

I recently wanted to set my blog's language to Romanian and I noticed that WordPress doesn't use the correct diacritical marks for Romanian. WP uses cedillas instead of commas ('ș' & 'ț' are correct, 'ş' & 'ţ' are not).

I guess it wouldn't be a big deal if WP didn't for some reason replace every correct diacritical mark on the blog upon switching the language. Although articles are written using the correct marks (commas), they display as incorrect (cedillas) when switching the language to Romanian.

This is pretty important, I hope you guys can fix this soon.

Thank you and keep up the good work!

Change History (12)

#1 @alexvorn2
4 years ago

:D Just use the characters you can type of the keyboard when switching to the romanian, very easy to check.

Last edited 4 years ago by alexvorn2 (previous) (diff)

#2 @alexvorn2
4 years ago

My using my keyboard...
Ș
ș
Ț
ț

#3 @ovidiuav
4 years ago

@alexvorn2 you seem to not understand the problem. i appreciate your input, but please don't post any further comments. thank you!

#4 in reply to: ↑ description ; follow-up: @SergeyBiryukov
4 years ago

  • Keywords reporter-feedback added

Hi @ovidiuav, welcome to WordPress Trac! Thanks for the report.

Replying to ovidiuav:

I recently wanted to set my blog's language to Romanian and I noticed that WordPress doesn't use the correct diacritical marks for Romanian. WP uses cedillas instead of commas ('ș' & 'ț' are correct, 'ş' & 'ţ' are not).

  1. Where exactly do you see incorrect diacritical marks? Does the issue happen on the front end or in WP admin?
  2. Does it still happen with all plugins disabled and a default theme (Twenty Seventeen) activated?

WordPress should not perform any character conversion like that by itself, this sounds like an issue with a particular font used in your theme.

#5 in reply to: ↑ 4 @ovidiuav
4 years ago

Replying to SergeyBiryukov:

Hi @ovidiuav, welcome to WordPress Trac! Thanks for the report.

Replying to ovidiuav:

I recently wanted to set my blog's language to Romanian and I noticed that WordPress doesn't use the correct diacritical marks for Romanian. WP uses cedillas instead of commas ('ș' & 'ț' are correct, 'ş' & 'ţ' are not).

  1. Where exactly do you see incorrect diacritical marks? Does the issue happen on the front end or in WP admin?
  2. Does it still happen with all plugins disabled and a default theme (Twenty Seventeen) activated?

WordPress should not perform any character conversion like that by itself, this sounds like an issue with a particular font used in your theme.

you know what, you're right, it's because of the font. also checked the Dashboard btw and WP is actually using the correct marks, so there's no WP issue after all.

however, the font supports both types of marks, it has no trouble displaying both of them when the blog is set to English. when i switch to Romanian, though, for some reason commas are displayed as cedillas (front end). any idea why that is?

thank you!

#6 @ovidiuav
4 years ago

  • Keywords reporter-feedback removed

#7 follow-up: @alexvorn2
4 years ago

  • Keywords close added

So it is a WordPress bug or font bug? As I understand it is a font bug so then let's proceed to close this ticket. thank you.

#8 @johnbillion
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

#9 in reply to: ↑ 7 @ovidiuav
4 years ago

  • Keywords close removed

Replying to alexvorn2:

So it is a WordPress bug or font bug? As I understand it is a font bug so then let's proceed to close this ticket. thank you.

again, thank you for your input. since the font supports both kinds of marks and the issue is triggered by an action within WP, i'm not sure what the problem is exactly and i was hoping @SergeyBiryukov or someone else might still be able to answer my question.

let's proceed to mind our own business, which i've already asked you to do when you first commented pointing out that cedillas are actually correct, when they aren't. you've since edited that part out, presumably when you spent the 10 seconds required to Google it and realized you don't know how to write in your own language, or that there are several keyboard layouts for Romanian (Legacy, Standard, and Programmers) and not all of them feature commas for diacritical marks, as it should be. so please, let me try and solve my issue without any more interference. thank you!

#10 @ovidiuav
4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#11 follow-up: @johnbillion
4 years ago

  • Component changed from Text Changes to I18N
  • Keywords reporter-feedback added

@ovidiuav Please mind your attitude to other people. Everyone in the WordPress community is voluntarily offering their free time to help you. Do not dare tell another volunteer to mind their own business.

That said, you mentioned that the issue does not occur in the WordPress admin area. Are you able to confirm the issue is still present if you use one of the default themes such as Twenty Seventeen? Thank you.

#12 in reply to: ↑ 11 @ovidiuav
4 years ago

  • Keywords reporter-feedback removed
  • Resolution set to worksforme
  • Status changed from reopened to closed

Replying to johnbillion:

@ovidiuav Please mind your attitude to other people. Everyone in the WordPress community is voluntarily offering their free time to help you. Do not dare tell another volunteer to mind their own business.

That said, you mentioned that the issue does not occur in the WordPress admin area. Are you able to confirm the issue is still present if you use one of the default themes such as Twenty Seventeen? Thank you.

hi John, i appreciate all the help, i'd appreciate that dude's replies too if he were actually trying to help.

i'm good though, thanks.

Note: See TracTickets for help on using tickets.