WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#41721 closed defect (bug) (duplicate)

WordPress will not connect to database using IPv6

Reported by: matty0501 Owned by:
Milestone: Priority: normal
Severity: blocker Version: 4.8.1
Component: Database Keywords:
Focuses: Cc:

Description

Hello,

I am trying to connect to a remote database using IPv6. I have configured the MySQL database bind address to that of the IPv6 address and created a database and issued all the required permissions.

When I go to install WordPress, I enter the IPv6 address and WordPress returns the following message "Error establishing a database connection". I have made sure my MySQL is working by using MySQL Client and it connects to the database without any problems.

I then did a little more digging and found that if I change the database bind address to a IPv4 address and configure the correct permissions, WordPress will install using an IPv4 address.

WordPress will not work with IPv6 address.

Thanks.

Change History (4)

#1 @matty0501
2 years ago

  • Severity changed from normal to blocker

This ticket was mentioned in Slack in #forums by sergey. View the logs.


2 years ago

#3 @Ipstenu
2 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #41722.

Closing in lieu of 41722 which has a little more technical details.

#4 @SergeyBiryukov
2 years ago

  • Component changed from General to Database
  • Milestone Awaiting Review deleted

Hi @matty0501, welcome to WordPress Trac! Thanks for the report.

#41722 was filed at the same time, but has a bit more details, so let's track the issue there.

Note: See TracTickets for help on using tickets.