WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#4173 closed defect (bug) (fixed)

upload.php page navigation goes to users.php?paged=xxx

Reported by: devil1591 Owned by: rob1n
Milestone: 2.2 Priority: normal
Severity: normal Version: 2.2
Component: Administration Keywords: upload has-patch
Focuses: Cc:

Description

The page navigation in upload.php links to users.php?paged=xxx

Attachments (1)

4173.diff (433 bytes) - added by johnbillion 8 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 @spencerp8 years ago

This must have been fixed since your post for this, and me SVN CO the 2.2 branch? Because at Manage > Upload link it's working. I'm not seeing that issue you're having?

http://2.2.spencerp.net/wp-admin/upload.php = Works fine for me, am I missing something maybe? I could be, I'm riding on -X hours of sleep here again. lol

Also, any links while after I uploaded an image and then browsed the uploaded image, works too. Nothing was breaking or sending me else where...

"links" = http://2.2.spencerp.net/wp-admin/upload.php?action=view&ID=4 = Worked!
"view" = http://2.2.spencerp.net/?attachment_id=4 = Worked!
"browse all" = http://2.2.spencerp.net/wp-admin/upload.php?action&ID=&tab=browse-all&paged = Worked!

comment:2 @devil15918 years ago

I confirm the bug, tested on a fresh svn 5290, in wp-admin/upload.php line 107, the bug is

'base' => 'users.php?%_%',

when you browse files, you get back to users.php

@johnbillion8 years ago

comment:3 @johnbillion8 years ago

Confirmed, patch attached.

comment:4 @johnbillion8 years ago

  • Keywords has-patch added

comment:5 @johnbillion8 years ago

  • Keywords has-patch removed

Ok my patch completely fails to fix anything at all. Excuse me while I go and get some sleep.

comment:6 @rob1n8 years ago

  • Priority changed from high to normal
  • Severity changed from blocker to normal

comment:7 @devil15918 years ago

  • Keywords has-patch added
  • Resolution set to fixed
  • Status changed from new to closed

this patch actually works, based on tests from duplicate ticket #4187

comment:8 @foolswisdom8 years ago

(In [5295]) Fix variable collission in _get_cat_children. see #3985

(In [5296]) Fix variable collission in _get_cat_children. For 2.2. see #3985

comment:9 @rob1n8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

It's only "fixed" when it's in the SVN :).

comment:10 @johnbillion8 years ago

As I said, this patch doesn't work. The changes made to upload.php in r5226 need to be reverted, as the changes in that revision were accidentally applied to upload.php instead of users.php unless I'm mistaken.

comment:11 @devil15918 years ago

johnbillion, the problem is in wp-admin/upload.php, when you navigate in uploads, the second page links to users.php?paged=xxx.

users.php does not have any problem.

comment:12 @johnbillion8 years ago

Am I right in thinking r5322 fixes this? I'm not in a position to test at the moment.

comment:13 follow-up: @foolswisdom8 years ago

Same fix is needed in 2.2, it looks like (r5324)

comment:14 @rob1n8 years ago

  • Owner changed from anonymous to rob1n
  • Status changed from reopened to new

comment:15 in reply to: ↑ 13 @foolswisdom8 years ago

Replying to foolswisdom:

Same fix is needed in 2.2, it looks like (r5324)

Oops, I should have said I was at r5324, I know see that it reads like r5324 was the fix.

comment:16 @rob1n8 years ago

  • Status changed from new to assigned

comment:17 @rob1n8 years ago

Both 2.2 and 2.3 currently have the same code. If it works in trunk, 99% sure it works in 2.2.

comment:18 @foolswisdom8 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Yeah, looks like it was fixed in r5369.

Note: See TracTickets for help on using tickets.