Make WordPress Core

Opened 7 years ago

Last modified 7 years ago

#41776 new enhancement

wp_list_category array element 'exclude' better be called 'exclude_id'

Reported by: subrataemfluence's profile subrataemfluence Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.8.1
Component: Taxonomy Keywords:
Focuses: Cc:


Could the default array element exclude of wp_list_category function be renamed as exclude_id?
I think only exclude is not that self explanatory and "what to exclude" could easily be a reasonable question for a developer to ask!

Instead exclude_id is easily understandable, even exclude_ids could be used as well because we can pass an array to it.

Please give it a thought.

Source file: wp-includes/category-template.php
Line no: 508

Change History (1)

#1 @SergeyBiryukov
7 years ago

  • Summary changed from wp_list_catgegory array element 'exclude' better be called 'exclude_id' to wp_list_category array element 'exclude' better be called 'exclude_id'
Note: See TracTickets for help on using tickets.