WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 11 months ago

#41779 closed defect (bug) (invalid)

TinyMCE plugins included with WordPress aren't loaded when using wp_enqueue_editor();

Reported by: Swennet Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.1
Component: Editor Keywords:
Focuses: Cc:

Description

Using the WP_Editor API as described on the following page does not load any of the WordPress specific TinyMCE plugins like it's supposed to do in the back-end.

https://make.wordpress.org/core/2017/05/20/editor-api-changes-in-4-8/

This seems like an oversight to me.

Change History (2)

#1 @azaozz
3 years ago

  • Keywords close added

Hmm, that's not the case? https://core.trac.wordpress.org/browser/tags/4.8/src/wp-includes/class-wp-editor.php#L814. All TinyMCE plugins that are included in WordPress are loaded except media, wpdialog (these are mostly redundant/deprecated), and wpview that needs special treatment to make it work.

Of course you're also free to add or remove plugins (or change any other setting) using the 'wp-before-tinymce-init' event: https://core.trac.wordpress.org/browser/tags/4.8/src/wp-admin/js/editor.js#L601.

#2 @pento
11 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket, as we're unable to reproduce this issue without more
information.

Note: See TracTickets for help on using tickets.