WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#41811 closed enhancement (invalid)

Update rest-api plugin readme to say it may not be needed

Reported by: samwilson Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: REST API Keywords:
Focuses: docs Cc:

Description

The documentation at https://wordpress.org/plugins/rest-api/ doesn't mention that this plugin is no longer required for people using 4.7 and above. (That's right isn't it? There isn't any functionality in it that isn't in core is there? Plugins that use the rest-api plugin can drop it if they only want to support 4.7 and up can't they?) The docs should be updated.

Change History (2)

#1 @swissspidy
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from trunk to 4.7

Trac is for working on WordPress core only, not any plugins. As the plugin readme says, all tickets for the project are being tracked on GitHub. It's best to submit an issue/PR there or ask for that in the REST API Slack channel.

Please note that the plugin does not do anything when running WordPRess 4.7. It stops running. Nothing breaks. It doesn't really matter if it's installed.

To answer your questions:

There isn't any functionality in it that isn't in core is there?

Not at the moment.

Plugins that use the rest-api plugin can drop it if they only want to support 4.7 and up can't they

Yes.

#2 @samwilson
4 years ago

Ah, good point. Thanks!

Sorry for the noise. :)

Note: See TracTickets for help on using tickets.