Make WordPress Core

Opened 7 years ago

Closed 15 months ago

Last modified 3 months ago

#41833 closed defect (bug) (invalid)

Excerpt disappear in excerpt mode post list, after quick edit

Reported by: satnapar's profile satnapar Owned by: ogekler's profile ogekler
Milestone: Priority: normal
Severity: normal Version: 4.8.1
Component: Quick/Bulk Edit Keywords: has-testing-info
Focuses: Cc:

Description

I am listing post in excerpt mode. I press quick edit and edit or not some post. Update and the excerpt disappears. Reload and the excerpt is there again

Attachments (1)

Screen-Shot-2017-09-08.jpg (235.6 KB) - added by satnapar 7 years ago.
Screenshot

Download all attachments as: .zip

Change History (23)

#1 follow-up: @ronakganatra
7 years ago

Can you please add screenshot ?

@satnapar
7 years ago

Screenshot

#3 @SergeyBiryukov
7 years ago

  • Component changed from Posts, Post Types to Quick/Bulk Edit

This ticket was mentioned in Slack in #core by abhanonstopnews. View the logs.


2 years ago

This ticket was mentioned in Slack in #core by nalininonstopnewsuk. View the logs.


2 years ago

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


2 years ago

#7 @webcommsat
2 years ago

Ticket raised in bug scrubs 14 March 2022 and requested testing in Dev Chat 16 March 2022.

Please test. Thanks

#8 @marybaum
2 years ago

@webcommsat just tested this and replicated the issue. I will test it too, and if I can replicate it too, it's a real thing, and it needs a patch.

This ticket was mentioned in Slack in #core by nalininonstopnewsuk. View the logs.


2 years ago

This ticket was mentioned in Slack in #core by david.baumwald. View the logs.


2 years ago

#11 @marybaum
2 years ago

The local site I use for testing runs 5.9.2 and Twenty Twenty-Two at the moment, and my Bulk/Quick Edit UI doesn't ever show the excerpt--doesn't even have a screen option to show it. Neither has, to my knowledge, any version of WordPress or Genesis, or any Genesis child theme I've ever used.

So I am completely unable to give gfood guidance on this.

This ticket was mentioned in Slack in #core by abhanonstopnews. View the logs.


2 years ago

#13 @sabernhardt
2 years ago

  • Keywords close added

This apparently has been fixed since 4.9 (in that version, I was able to reproduce the missing excerpt after using Quick Edit on a post).

I'll look for what fixed it so I can set the resolution to "fixed" instead of just "works for me" :)

#14 @sabernhardt
2 years ago

  • Keywords needs-testing added; close removed

I was wrong. The installation in which I reproduced the error used Polylang, and that includes the language as an option in quick edit. Adding the plugin in 5.9 has the same issue.

Needs further testing with other plugins that add to the quick edit form to determine whether it is caused by Polylang only or by any plugin's quick edit fields.

This ticket was mentioned in Slack in #core by abhanonstopnews. View the logs.


19 months ago

#16 @marybaum
19 months ago

Okay. I installed Polylang, and the behavior I get is the same either way: the excerpt does disappear while the Quick Edit screen is up, but it comes back as soon as I update.

That's on 6.1 beta 3, running Twenty Twenty Three.

#17 @oglekler
15 months ago

It needs to be checked if this issue appeares only with the Polylang. If this is the case, this could be addressed with Polylang development team rather with the WordPress Core.

Needs futher testing.

Attendees of the component review: @marybaum @webcommsat @oglekler @nalininonstopnewsuk

#18 @marybaum
15 months ago

  • Owner set to ogekler
  • Status changed from new to reviewing

This ticket was mentioned in Slack in #core by marybaum. View the logs.


15 months ago

#20 @oglekler
15 months ago

  • Keywords has-testing-info added; needs-testing removed
  • Resolution set to invalid
  • Status changed from reviewing to closed

I tested Quick edit on WordPress 4.8.21 and 6.1.1 without Polylang and with it (version 2.2.6 and 3.3.1 accordingly). This behavior is only happening with Polylang and hereby Polylang team needs to be addressed with this long going issue. The response from the server itself has an excerpt to update the post row, and then it is removed. So, the source of this in some Polylang JS code which works in the Dashboard.

I am resolving this issue as invalid. It can be opened again if there will be an information that behavior in question is happening due to circumstances, which needs to be fixed in the Core. I want to point that the Excerpt in the row has no own wrapper between post title and other elements in the table cell and this is probably confusing js making some manipulations with the cell content. But to make an additional wrapper, we need to have more reasons than one case we cannot be sure at.

This ticket was mentioned in Slack in #core by oglekler. View the logs.


15 months ago

#22 @swissspidy
3 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.