WordPress.org

Make WordPress Core

Opened 12 days ago

Closed 11 days ago

#41840 closed defect (bug) (fixed)

Uncaught ReferenceError: jQuery is not defined on admin pages

Reported by: imabug Owned by:
Milestone: 4.9 Priority: normal
Severity: normal Version: trunk
Component: Administration Keywords:
Focuses: javascript Cc:

Description

WordPress 4.9-alpha-41352
Google Chrome beta 61.0.3163.79

The back end pages are all producing numerous

Uncaught ReferenceError: jQuery is not defined

errors. Previous alpha version worked fine, and another WP 4.8.1 installation I'm running is also working fine.

akismet.js?ver=3.3.4:1 Uncaught ReferenceError: jQuery is not defined
    at akismet.js?ver=3.3.4:1
(anonymous) @ akismet.js?ver=3.3.4:1
index.php:82 Uncaught ReferenceError: jQuery is not defined
    at index.php:82
(anonymous) @ index.php:82
index.php:703 Uncaught ReferenceError: jQuery is not defined
    at index.php:703
(anonymous) @ index.php:703
tracks-ajax.js?ver=5.3:49 Uncaught ReferenceError: jQuery is not defined
    at tracks-ajax.js?ver=5.3:49
(anonymous) @ tracks-ajax.js?ver=5.3:49
jetpack-jitm.js?ver=5.3:1 Uncaught ReferenceError: jQuery is not defined
    at jetpack-jitm.js?ver=5.3:1
(anonymous) @ jetpack-jitm.js?ver=5.3:1
notes-common-v2.js?ver=5.3-201736:158 Uncaught ReferenceError: jQuery is not defined
    at notes-common-v2.js?ver=5.3-201736:158
(anonymous) @ notes-common-v2.js?ver=5.3-201736:158
admin-bar-v2.js?ver=5.3-201736:2 Uncaught ReferenceError: _ is not defined
    at admin-bar-v2.js?ver=5.3-201736:2
(anonymous) @ admin-bar-v2.js?ver=5.3-201736:2
wpgroho.js?ver=7079b6880f748236905f4c1bf36d5745:2 Uncaught ReferenceError: jQuery is not defined
    at wpgroho.js?ver=7079b6880f748236905f4c1bf36d5745:2
(anonymous) @ wpgroho.js?ver=7079b6880f748236905f4c1bf36d5745:2

Change History (3)

#1 @SergeyBiryukov
11 days ago

  • Component changed from General to Administration
  • Keywords reporter-feedback added

Hi @imabug, welcome to WordPress Trac! Thanks for the report.

I can't reproduce the issue on a clean install. Does it still happen with all plugins disabled and a default theme (Twenty Seventeen) activated? Does it happen if you reinstall WordPress?

#2 @imabug
11 days ago

I went to make a new blog post, but found that while I could enter a blog title, I wasn't able to type anything in the body text field. This is what prompted me to file a bug report since I didn't have any issues with the prior alpha versions.

Using the Twenty Seventeen theme.

Using the Beta Tester plugin, I downgraded to 4.8.1, disabled plugins and verified that everything worked fine. Used the Beta Tester plugin to upgrade back to the most recent alpha build (WordPress 4.9-alpha-41352). Plugins still disabled (except for the Beta Tester plugin).

Now the error in Chrome's Javascript console is

wp-tinymce.php?c=1&ver=4603-20170530:47 Uncaught ReferenceError: getUserSetting is not defined
    at b.onPostRender (wp-tinymce.php?c=1&ver=4603-20170530:47)
    at b.c (wp-tinymce.php?c=1&ver=4603-20170530:25)
    at b.e [as fire] (wp-tinymce.php?c=1&ver=4603-20170530:11)
    at b.fire (wp-tinymce.php?c=1&ver=4603-20170530:11)
    at b.postRender (wp-tinymce.php?c=1&ver=4603-20170530:11)
    at b.postRender (wp-tinymce.php?c=1&ver=4603-20170530:12)
    at b.postRender (wp-tinymce.php?c=1&ver=4603-20170530:11)
    at b.<anonymous> (wp-tinymce.php?c=1&ver=4603-20170530:11)
    at Object.b [as each] (wp-tinymce.php?c=1&ver=4603-20170530:3)
    at b.each (wp-tinymce.php?c=1&ver=4603-20170530:11)
onPostRender @ wp-tinymce.php?c=1&ver=4603-20170530:47
c @ wp-tinymce.php?c=1&ver=4603-20170530:25
e @ wp-tinymce.php?c=1&ver=4603-20170530:11
fire @ wp-tinymce.php?c=1&ver=4603-20170530:11
postRender @ wp-tinymce.php?c=1&ver=4603-20170530:11
postRender @ wp-tinymce.php?c=1&ver=4603-20170530:12
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
b @ wp-tinymce.php?c=1&ver=4603-20170530:3
each @ wp-tinymce.php?c=1&ver=4603-20170530:11
exec @ wp-tinymce.php?c=1&ver=4603-20170530:11
postRender @ wp-tinymce.php?c=1&ver=4603-20170530:11
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
b @ wp-tinymce.php?c=1&ver=4603-20170530:3
each @ wp-tinymce.php?c=1&ver=4603-20170530:11
exec @ wp-tinymce.php?c=1&ver=4603-20170530:11
postRender @ wp-tinymce.php?c=1&ver=4603-20170530:11
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
postRender @ wp-tinymce.php?c=1&ver=4603-20170530:16
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
b @ wp-tinymce.php?c=1&ver=4603-20170530:3
each @ wp-tinymce.php?c=1&ver=4603-20170530:11
exec @ wp-tinymce.php?c=1&ver=4603-20170530:11
postRender @ wp-tinymce.php?c=1&ver=4603-20170530:11
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
b @ wp-tinymce.php?c=1&ver=4603-20170530:3
each @ wp-tinymce.php?c=1&ver=4603-20170530:11
exec @ wp-tinymce.php?c=1&ver=4603-20170530:11
postRender @ wp-tinymce.php?c=1&ver=4603-20170530:11
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:11
renderBefore @ wp-tinymce.php?c=1&ver=4603-20170530:11
p @ wp-tinymce.php?c=1&ver=4603-20170530:19
k @ wp-tinymce.php?c=1&ver=4603-20170530:19
renderUI @ wp-tinymce.php?c=1&ver=4603-20170530:19
n @ wp-tinymce.php?c=1&ver=4603-20170530:14
q @ wp-tinymce.php?c=1&ver=4603-20170530:14
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:14
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:5
b @ wp-tinymce.php?c=1&ver=4603-20170530:3
r @ wp-tinymce.php?c=1&ver=4603-20170530:5
loadScripts @ wp-tinymce.php?c=1&ver=4603-20170530:5
loadQueue @ wp-tinymce.php?c=1&ver=4603-20170530:5
n @ wp-tinymce.php?c=1&ver=4603-20170530:14
o @ wp-tinymce.php?c=1&ver=4603-20170530:14
render @ wp-tinymce.php?c=1&ver=4603-20170530:14
e @ wp-tinymce.php?c=1&ver=4603-20170530:15
(anonymous) @ wp-tinymce.php?c=1&ver=4603-20170530:15
b @ wp-tinymce.php?c=1&ver=4603-20170530:3
m @ wp-tinymce.php?c=1&ver=4603-20170530:15
a @ wp-tinymce.php?c=1&ver=4603-20170530:3
p @ wp-tinymce.php?c=1&ver=4603-20170530:3
i @ wp-tinymce.php?c=1&ver=4603-20170530:3
wp-tinymce.php?c=1&ver=4603-20170530:11 Uncaught TypeError: Cannot read property 'parents' of undefined
    at HTMLDivElement.d (wp-tinymce.php?c=1&ver=4603-20170530:11)
    at a (wp-tinymce.php?c=1&ver=4603-20170530:3)
    at HTMLDivElement.p (wp-tinymce.php?c=1&ver=4603-20170530:3)
d @ wp-tinymce.php?c=1&ver=4603-20170530:11
a @ wp-tinymce.php?c=1&ver=4603-20170530:3
p @ wp-tinymce.php?c=1&ver=4603-20170530:3

Maybe this is the actual error causing me problems instead of the jQuery errors I initially reported?

Last edited 11 days ago by imabug (previous) (diff)

#3 @SergeyBiryukov
11 days ago

  • Keywords reporter-feedback removed
  • Milestone changed from Awaiting Review to 4.9
  • Resolution set to fixed
  • Status changed from new to closed

Looks like [41352] was the culprit here, see comment:17:ticket:41610.

Fixed in [41360], should be resolved once the next nightly build is generated.

Note: See TracTickets for help on using tickets.