WordPress.org

Make WordPress Core

#41883 closed defect (bug) (fixed)

Press This: JS error "Cannot read property 'stripTags' of undefined"

Reported by: afercia Owned by: adamsilverstein
Milestone: 4.9 Priority: normal
Severity: normal Version: 4.9
Component: Press This Keywords: needs-patch
Focuses: javascript Cc:

Description

To reproduce:

  • access Press This from wp-admin/press-this.php (haven't tried the bookmarklet)
  • try to Publish, Save, or switch to "Standard Editor"
  • observe your browser console:

Uncaught TypeError: Cannot read property 'stripTags' of undefined

/cc @adamsilverstein

Attachments (1)

41883.diff (639 bytes) - added by adamsilverstein 22 months ago.

Download all attachments as: .zip

Change History (6)

#1 @adamsilverstein
22 months ago

  • Owner set to adamsilverstein
  • Status changed from new to assigned

Oops, thanks for catching @afercia - I see the issue, fix incoming.

#2 @kraftbj
22 months ago

Whew, I was just starting to look into this relative to #41689. I thought I broke something there.

#3 @afercia
22 months ago

@adamsilverstein great, thanks! 🍷

#4 @adamsilverstein
22 months ago

41883.diff fixes it that issue, must have broken before the final commit. good argument for adding urit tests here.

#5 @adamsilverstein
22 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 41379:

wp.sanitize - fix namespace for calls to stripTags.

Fixes an undefined JavaScript error in PressThis since [41061].

Props afercia.
Fixes #41883.

Note: See TracTickets for help on using tickets.