WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 12 months ago

#41892 closed defect (bug) (invalid)

Widgets Disappear from Admin 4.8.1

Reported by: judyvedder Owned by: audrasjb
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords:
Focuses: Cc:

Description

I have seen similar reports of this bug - such as #41659 - I am hoping that this additional detail will get this bug higher in the list to fix.

I have a copy of a website in a test environment. If I add a widget to a sidebar that was on the website prior to upgrading to 4.8.1, such as "Custom Menu" or "Recent Posts" it appears to behave correctly. However, I have added three new plug-ins: "jQuery Archive List Widget", "List Custom Taxonomy Widget", and "Collapsing Archives" since the upgrade. I have done the below testing with each plug-in being the only active plug-in.

When I put one of the widgets in a sidebar and save, I can go to the page where the sidebar is and see the widget functionality (sometimes), but when I return to the widget admin area the widget is no longer listed in the sidebar. When you go back to the page the sidebar functionality is no longer showing. It just disappears!

It seems that when you add the widget back to the sidebar multiple times the plug-in functionality does not always show on the page with the sidebar. It just stops working.

I have confirmed this behavior with ALL plug-ins disabled, except for one of the new plug-ins I listed above, and theme Twenty Sixteen activated.

I am hoping that this issue can get resolved asap.

Change History (4)

#1 @joyously
3 years ago

What version of WordPress did you upgrade from?
It sounds like you didn't test these 3 plugins on the previous version of WordPress, so how do you know the problem isn't in the plugins? (or the theme?)
To be clear, you are referring to the Widget admin page, and not the Customizer, is that correct?

#2 @judyvedder
3 years ago

The website was upgraded from 4.6. No, the 3 plug-ins were not tested on the website prior to upgrade. They are new installs post upgrade. I explained in my ticket that I removed ALL plug-ins, except the widget I was testing, and went to the Twenty Sixteen theme where I saw the same behavior as I did with the custom theme. That is why I do not think it is theme related.

It seems that I would have really unfortunate luck if I just happened to pick three plug-ins that all have a bug that makes them disappear out of the sidebar in the widget Admin area. In addition, I have seen several people sharing similar widget issues in 4.8.1. In my case, it appears that widgets that were on the website prior to upgrade work fine. When I add the new plug-ins they do not work fine. Not 100% sure it has anything to do with upgrading, but I was trying to offer some information that might lead to the correction of this issue. I am currently dead in the water on my site.

Yes, I am talking about the Widget Admin area.

If a developer who can work on a fix for this issue wants to access my test environment to see this first-hand I would be happy to give you access to my website.

#3 @audrasjb
17 months ago

  • Keywords close reporter-feedback added
  • Owner set to audrasjb
  • Status changed from new to assigned

Hi and welcome to WordPress Trac,

Sorry for the delay, but it looks like a plugin issue. Do you reproduce the issue with the current version of WordPress?

Adding close (and reporter-feedback) keyword because it's probably not a Core issue.

#4 @audrasjb
12 months ago

  • Keywords close reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from assigned to closed
  • Version 4.8.1 deleted

Hi,

I'm closing this ticket as it looks like a plugin issue and because there were no reporter feedback in few months. Feel free to reopen it if needed.

Cheers,
Jb

Note: See TracTickets for help on using tickets.