WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 18 months ago

Last modified 18 months ago

#41935 closed defect (bug) (invalid)

Dashboard WordPress Events and News showing duplicate Meetup postings

Reported by: kamamarketing Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Administration Keywords: needs-patch good-first-bug
Focuses: Cc:

Description

We run the Triad WordPress Meetup in North Carolina. I put place holder meetups in the calendar using the "recurring meeting" feature in Meetup and it alerts people when the next meetings will be even though we don't have topics/speakers lined up yet. As I confirm speakers and topics i go in to Meetup and edit the Topic, the information and details. It seems to be working fine.

However, the WordPress dashboard appears to collect the info on the original TBD meeting and holds on to it. It IS ALSO picking up the new information and publishes that too. But on the listing it shows two meetings on that date with the topic for one to be determined (TBD). It might have to do with the fact that I changed the location also. If you're placing a premium on location trying to serve up events near the logged in user that could be it and it might go away since I've updated the location in the template.

Thanks for all you do. I just thought if it was happening here it might be in other places.

Attachments (2)

Screen Shot 2017-09-20 at 1.39.23 PM.png (72.6 KB) - added by kamamarketing 19 months ago.
Screen shot of dashboard
duplicate-dashboard-event.jpg (35.1 KB) - added by subrataemfluence 19 months ago.

Download all attachments as: .zip

Change History (6)

@kamamarketing
19 months ago

Screen shot of dashboard

#1 @subrataemfluence
19 months ago

  • Component changed from General to Widgets
  • Keywords needs-patch added
  • Version changed from trunk to 4.8.2

Hi @kamamarketing Welcome to WordPress Trac. I could reproduce the issue! I am adding a screenshot in support to your ticket. I am on 4.8.2

#2 @subrataemfluence
19 months ago

When I inspected the endpoint with location Mumbai (https://api.wordpress.org/events/1.0/?location=mumbai) I found that two Meetup events are returned with same Id (241167323), but surprisingly the latitude and longitude values are different! The meetup URL is https://www.meetup.com/Mumbai-WordPress-Meetup/events/241167323/.

Question is how two records with same ID can reside in database unless it is not the primary key. And are lat and lon being determined dynamically when the records are fetched? Only then they could be a little different (not always though). If that information was stored in database upfront, they cannot be different.

Last edited 19 months ago by subrataemfluence (previous) (diff)

#3 @iandunn
18 months ago

  • Component changed from Widgets to Administration
  • Keywords good-first-bug added
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 4.8.2 to 4.8

Thanks for pointing this out @kamamarketing, and @subrataemfluence for confirming it.

It looks to be an API-side issue, so the best place to work on it will be the Meta Trac. It looks like it's already been reported there in #meta3027 (which is related to #meta2720).

Both of those tickets are still in need of a contributor, if either of you would like to submit a patch. The Meta handbook has some general documentation about contributing to Meta projects, which is pretty similar to contributing to Core. The Meta Environment doesn't have the API setup in it yet, but I'd be happy to help you set your environment if you want to tackle this. Just ping me in the meta channel on Slack.

This ticket was mentioned in Slack in #meta by subratasarkar. View the logs.


18 months ago

Note: See TracTickets for help on using tickets.