WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 14 months ago

#41943 closed feature request (worksforme)

Color changing for URL in Editor

Reported by: lumay Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.2
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

In Wordpres 4.8.x, after color changing for URL in Editor, there is following html code placing:

<span style="color: #000000;"><a href="">URL</a></span>

before was:

<span style="color: #000000"><a style="color: #000000;" href=""">URL</a></span> 

And it was correct for me. Now I have to changing every link in HTML editor to add span code for link color - could you please fix or add option for that?

Thank you in advance!

Attachments (6)

Zrzut ekranu 2017-09-21 o 16.48.44.png (56.7 KB) - added by lumay 3 years ago.
Zrzut ekranu 2017-09-21 o 16.48.44.2.png (56.7 KB) - added by lumay 3 years ago.
Zrzut ekranu 2017-09-21 o 16.48.52.png (76.3 KB) - added by lumay 3 years ago.
Zrzut ekranu 2017-09-21 o 16.48.18.png (117.4 KB) - added by lumay 3 years ago.
Zrzut ekranu 2017-09-21 o 16.55.03.png (70.8 KB) - added by lumay 3 years ago.
Zrzut ekranu 2017-09-21 o 16.55.09.png (103.0 KB) - added by lumay 3 years ago.

Download all attachments as: .zip

Change History (11)

#1 follow-up: @subrataemfluence
3 years ago

  • Keywords reporter-feedback added

Welcome to Trac and thank you for the ticket.

By Editor are you referring to Visual Editor where you are creating your posts?
Can you please tell me the steps to reproduce the issue?

#2 in reply to: ↑ 1 @lumay
3 years ago

Replying to subrataemfluence:

Welcome to Trac and thank you for the ticket.

By Editor are you referring to Visual Editor where you are creating your posts?
Can you please tell me the steps to reproduce the issue?

Of course

  1. First I typing text f.ex. www.example.com and select URL from editor
  2. select text and choose colors for text and URL, and only text is in selected color, URL is not changed

Attached please find screens.

#3 follow-up: @subrataemfluence
3 years ago

@lumay Thank you for your detailed response. One thing though.

Can you meanwhile try this please and see if you can still reproduce the same?

  1. Deactivate all plugins.
  2. Switch back to a default theme like twentyseventeen.

Please let me know what you find.

#4 in reply to: ↑ 3 @lumay
3 years ago

I can't do that on this specific website, because it is online, but I will try to do that on another project.

#5 @pento
14 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I'm unable to reproduce this on a site with no plugins and a default theme.

Please re-open this ticket if you have steps to reproduce it.

Note: See TracTickets for help on using tickets.