Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#41948 closed defect (bug) (fixed)

White .png images files (with transparent background) not visible in media library

Reported by: stevepuddick's profile stevepuddick Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 4.9 Priority: normal
Severity: normal Version:
Component: Media Keywords: good-first-bug has-patch
Focuses: Cc:

Description

This is a follow-up to #15860. The issue is very similar.

The attached screenshots depict the issue easily. If you are viewing a pure white .png image with a transparent background, the image does not appear to be there visually since the background of the modal window is also white. I propose adding some CSS to the modal so it contains a grey/white checkered background. This checkered background seems to be emerging as the standard for displaying transparent backgrounds. This is present in Photoshop, Google image search results, etc.

Attachments (3)

modal-no-grid.png (93.0 KB) - added by stevepuddick 7 years ago.
A picture of a white apple is present, but not visible
modal-with-grid.png (124.1 KB) - added by stevepuddick 7 years ago.
A picture of a white apple is present, but is visible because of the checkered background.
41948.patch (613 bytes) - added by powerzilly 7 years ago.
Fix background problem

Download all attachments as: .zip

Change History (10)

@stevepuddick
7 years ago

A picture of a white apple is present, but not visible

@stevepuddick
7 years ago

A picture of a white apple is present, but is visible because of the checkered background.

#1 @SergeyBiryukov
7 years ago

  • Keywords needs-patch good-first-bug added
  • Milestone changed from Awaiting Review to Future Release

Related: #33299

@powerzilly
7 years ago

Fix background problem

#2 @powerzilly
7 years ago

  • Keywords has-patch added; needs-patch removed

#3 @SergeyBiryukov
7 years ago

  • Milestone changed from Future Release to 4.9
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

#4 @SergeyBiryukov
7 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 41569:

Media: Improve the preview of transparent images in Attachment Details modal by using CSS3 to show a checkered background.

Props powerzilly, stevepuddick.
Fixes #41948.

#5 @SergeyBiryukov
7 years ago

In 41742:

Media: Improve the preview of transparent images in Edit Image modal by using CSS3 to show a checkered background.

Props powerzilly, stevepuddick.
Fixes #41966. See #41948.

#6 @SergeyBiryukov
6 years ago

In 42642:

Media: Remove checkered background for icons in Attachment Details.

Props BandonRandon.
Fixes #42535. See #41948.

#7 @SergeyBiryukov
6 years ago

In 43745:

Media: Remove checkered background for icons in Attachment Details.

Props BandonRandon.
Merges [42642] to the 5.0 branch.
Fixes #42535. See #41948.

Note: See TracTickets for help on using tickets.