WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 19 months ago

Last modified 19 months ago

#41988 closed enhancement (duplicate)

Strict comparison for JavaScript type of check at line 110 in wp-admin/admin-footer.php

Reported by: rnaby Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: General Keywords: 2nd-opinion
Focuses: Cc:
PR Number:

Description

The typeof checking for wpOnload variable should use === comparison operator rather than == comparison operator. It'll make variable type checking strict.

Before or now the code is-

<script type="text/javascript">if(typeof wpOnload=='function')wpOnload();</script>

After applying the fix, the code is-

<script type="text/javascript">if(typeof wpOnload==='function')wpOnload();</script>

Attachments (1)

41988.diff (466 bytes) - added by rnaby 2 years ago.
The diff patch file I generated by using RabbitVCS.

Download all attachments as: .zip

Change History (4)

@rnaby
2 years ago

The diff patch file I generated by using RabbitVCS.

#1 @swissspidy
2 years ago

  • Keywords 2nd-opinion added
  • Priority changed from normal to low
  • Version trunk deleted

Please note that there's #41057 to apply PHP coding standards in core once and for all. Perhaps we need a similar ticket for JS? That would be much easier than having dozens of very small tickets for things not really worth fixing on their own. In this particular section there's no bug caused by these comparisons anyway.

#2 @rnaby
19 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #41057.

#3 @SergeyBiryukov
19 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.