WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 19 months ago

Last modified 19 months ago

#41989 closed enhancement (duplicate)

Some PHP and JavaScript type checking strict rule should be applied in wp-admin/admin-header.php

Reported by: rnaby Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: Administration Keywords: 2nd-opinion
Focuses: Cc:
PR Number:

Description

Some PHP and JavaScript strict type checking should be done at wp-admin/admin-header.php file. Patch is attached. Please have look.

Attachments (1)

41989.diff (1.3 KB) - added by rnaby 2 years ago.

Download all attachments as: .zip

Change History (4)

@rnaby
2 years ago

#1 @swissspidy
2 years ago

  • Keywords 2nd-opinion added
  • Priority changed from normal to low
  • Version trunk deleted

Please note that there's #41057 to apply PHP coding standards in core once and for all. Perhaps we need a similar ticket for JS? That would be much easier than having dozens of very small tickets for things not really worth fixing on their own. In this particular section there's no bug caused by these comparisons anyway.

#2 @rnaby
19 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #41057.

#3 @SergeyBiryukov
19 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.