Make WordPress Core

Opened 7 years ago

Closed 2 weeks ago

#42035 closed defect (bug) (duplicate)

Twenty Fourteen: Non-Responsive Sub-Menus on iPad Pro in Horizontal View

Reported by: katinthehatsite's profile katinthehatsite Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.2
Component: Bundled Theme Keywords: needs-testing
Focuses: Cc:

Description

It seems that the sub-menu items are not responsive and do not work on some devices such as iPad Pro in the theme Twenty Fourteen when the device is in the horizontal view.

The steps to reproduce:

  • activate the theme Twenty Fourteen;
  • create a menu with sub-menu items in the Appearance - Customize;
  • select the display location for the menu to be "Top Primary Menu";
  • save and publish your settings;
  • go to your site on iPad Pro and try clicking on the menu to make a sub-menu appear in the
  • horizontal view.

What I expected:

the sub-menu items to appear

What happened:

the sub-menus did not appear and were not responsive

Further details:

I tested on iPad Pro and iPad 4; the issue seems to be happening on iPad Pro specifically - I suspect because it has a desktop view in the horizontal position where you can see all of the items.

On iPad 4, the menu is a hamburger menu, and once you click to open it, all menu items are visible.

Change History (4)

#1 @SergeyBiryukov
6 years ago

  • Summary changed from Non-Responsive Sub-Menus on iPad Pro in Horizontal View to Twenty Fourteen: Non-Responsive Sub-Menus on iPad Pro in Horizontal View

#2 @karmatosed
4 months ago

  • Keywords needs-testing added

#3 @poena
3 months ago

I believe this is a duplicate of https://core.trac.wordpress.org/ticket/30575

I tested the "desktop" menu on ipadOS 16.7.6 using chrome. It is significantly better than on the smaller android phone.
On my ipad, the submenu expands on the first click, but I am not redirected instantly like I am on the android, and I am able to select the submenu item.

On first click on the parent menu item, the submenu shows.
On second click on the parent menu item, I am redirect to the page that the parent menu item links to.

Last edited 3 months ago by poena (previous) (diff)

#4 @karmatosed
2 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #30575.

I also agree this is a duplicate @poena and I am going to close it as such thank you everyone.

Note: See TracTickets for help on using tickets.