WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#42062 closed defect (bug) (duplicate)

On Update Plugins, "Select All" does not always select all

Reported by: Presskopp Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Upgrade/Install Keywords:
Focuses: administration Cc:

Description

When there are more plugins to update, and you are on wp-admin/update-core.php

you'll see:

The following plugins have new versions available. Check the ones you want to update and then click “Update Plugins”. You can also "Select all". But if you do this early, sometimes only the checkbox itself gets marked, not the plugins, see screenshot. This could lead to the impression it would be normal like this and when you update, nothing is updated. At least ist a unwanted glitch, if you ask me. Screenshot follows (german, sorry)

Attachments (1)

plugins.png (11.3 KB) - added by Presskopp 4 years ago.

Download all attachments as: .zip

Change History (5)

@Presskopp
4 years ago

#1 @swissspidy
4 years ago

But if you do this early, sometimes only the checkbox itself gets marked, not the plugins, see screenshot.

Early as in, the page hasn't fully loaded yet? Most JS is loaded in the footer, so when WordPress is fetching the updates, it blocks rendering of the footer for a while and that JavaScript loads a bit later.

Can you confirm this doesn't happen after a page reload? WordPress caches the update results and the page loads faster after that.

#2 @Presskopp
4 years ago

I had to update several sites and it was happening several times. It seems to be like you explained, that's why I said 'early'. Will see if I can reproduce or test more, but now that's all I can tell.

#3 @Presskopp
4 years ago

I now tried on localhost and I had a hard time reproducing it. But finally I did. It can happen after you reload the page (no hard reload, not empty cache), but it will happen very rarely.

#4 @SergeyBiryukov
4 years ago

  • Component changed from General to Upgrade/Install
  • Focuses administration added
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27511.

Note: See TracTickets for help on using tickets.