WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 3 months ago

#42099 closed defect (bug) (worksforme)

Serious Bug with iOS and Safari when Using any External Keyboard

Reported by: ppayne Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.4
Component: Editor Keywords:
Focuses: Cc:

Description (last modified by noisysocks)

There's a serious bug in WordPress that's happened with all recent versions of iOS (iPad or iPhone) and most major browsers, including Safari and Chrome. Basically, the arrow keys used to move the text cursor while editing a blog post nearly always execute either a page down or scroll to end of document command. It's extremely frustrating and makes it impossible to use Wordpress for writing on an iOS device with one of these browsers.

The bug happens with any iOS device and has been with us for the last 2-3 years at least. iPad and Bluetooth keyboard (third party or Apple) as well as Apple's keyboard cover have the problem. I have reported it to issue but they are engineers, and engineers don't use blog platforms, so my sense is that they're not interested in fixing it on their end.

The bug happens with the current versions of iOS too, HOWEVER not with all browsers. At least two, Dolphin and Opera Mini, do not exhibit the frustrating screen jumping bug, therefore I use Dolphin for editing. But the bug does happen in Safari and Chrome, and I believe Firefox.

I will attempt to attach a video showing what happens to the screen when arrow keys are pressed during editing of a WP blog on iOS.

Attachments (1)

IMG_1145a.mov (6.6 MB) - added by ppayne 2 years ago.
Showing what happens when the bug occurrs, by typing an arrow key while editing any blog post in iOS

Change History (3)

@ppayne
2 years ago

Showing what happens when the bug occurrs, by typing an arrow key while editing any blog post in iOS

This ticket was mentioned in Slack in #core by noisysocks. View the logs.


3 months ago

#2 @noisysocks
3 months ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hey @ppayne! I tested this with WordPress 5.3.9 and iOS 13.1.3 running on my iPhone 11 with an external Bluetooth keyboard and was not able to reproduce the issue. It might be that a plugin is causing this issue. Try temporarily disabling all plugins and seeing if that helps.

Note: See TracTickets for help on using tickets.