WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#42103 closed defect (bug) (duplicate)

Impose an changelog when submitting an update

Reported by: Djibs13 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org Site Keywords:
Focuses: Cc:

Description

Many plugins are updated without adding a list of changes or new features. It is very important for users to know what changes when they will update the plugin.

Sometimes it takes several days before an changelog apapraises on the plugin page; sometimes it is several weeks.

Changelog should be imposed at the time of submission. It should have been done for a long time.

This also applies to the Wordpress team. For example, the WP-Super Cache Plugin has been updated to version 1.5.6 and still no changelog after more than 24 hours on the plugin page.

Attachments (1)

DJIBS 2017-10-05 à 10.19.44.jpg (1.1 MB) - added by Djibs13 4 years ago.

Download all attachments as: .zip

Change History (4)

#1 @danieltj
4 years ago

  • Keywords close added

Sometimes it just takes time for the plugin directory to show the latest updated changelog. I don't think I've seen a plugin not updating it's readme.txt with a change log. If for whatever reason a change log isn't included or updated the plugin author might just need a nudge so they can make/update it is all.

#2 @swissspidy
4 years ago

  • Keywords close removed

@danieltj That's not the problem. The problem is the version in the iframe seems to be heavily cached.

#3 @ocean90
4 years ago

  • Component changed from Plugins to WordPress.org site
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.