Make WordPress Core

Opened 7 years ago

Closed 2 years ago

#42109 closed defect (bug) (duplicate)

Code Editor: shouldAutocomplete not working for php

Reported by: tharsheblows's profile tharsheblows Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Plugins Keywords: has-patch
Focuses: Cc:

Description

To reproduce:

  • go to a php bit in the code in the code editor
  • start typing "pri" and it should bring up "private", "print", "printf" etc

I think it's good that this doesn't work! It'd be great if it helped with WordPress functions too but it's just php so it's a little confusing when it does work (to me at least :) ). So here are two patches, one with it working and one with it taken out.

Attachments (2)

42109-working.diff (700 bytes) - added by tharsheblows 7 years ago.
php autocomplete working
42109-removed.diff (691 bytes) - added by tharsheblows 7 years ago.
the php autocomplete bit removed

Download all attachments as: .zip

Change History (5)

@tharsheblows
7 years ago

php autocomplete working

@tharsheblows
7 years ago

the php autocomplete bit removed

#1 @swissspidy
7 years ago

  • Component changed from General to Plugins
  • Keywords has-patch needs-testing added

#2 @azouamauriac
2 years ago

  • Keywords needs-refresh reporter-feedback added

Hello there, wasn't able to reproduce your report, please can you provide more details(like screenshot, or video...).
thanks.

#3 @SergeyBiryukov
2 years ago

  • Keywords needs-testing needs-refresh reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like this was fixed in [45670] / #47769.

This ticket was submitted earlier, sorry I haven't seen it before.

Note: See TracTickets for help on using tickets.