WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#42113 closed defect (bug) (fixed)

Customize Menus: Copy updates

Reported by: melchoyce Owned by: westonruter
Milestone: 4.9 Priority: normal
Severity: normal Version: 4.9
Component: Customize Keywords: has-patch commit
Focuses: ui Cc:

Description

We need to update the New Menu —> Menu Locations description to speak better to new menus.

Attachments (3)

new-menu-location-description.png (196.8 KB) - added by bpayton 4 years ago.
create-menu-before-after-20171011a.png (226.5 KB) - added by bpayton 4 years ago.
edit-menu-before-after-20171011a.png (243.5 KB) - added by bpayton 4 years ago.
Edit Menu: Margin is improved for Menu Options

Download all attachments as: .zip

Change History (18)

#1 @melchoyce
4 years ago

  • Owner set to bpayton
  • Status changed from new to assigned

#2 follow-up: @bpayton
4 years ago

The attached mock is larger than I intended, but it's fine for reference.

@melchoyce What do you want "widget" to link to?
Maybe https://codex.wordpress.org/WordPress_Widgets ?

#3 in reply to: ↑ 2 @melchoyce
4 years ago

Replying to bpayton:

@melchoyce What do you want "widget" to link to?
Maybe https://codex.wordpress.org/WordPress_Widgets ?

Yup! (Sadly, there's no Codex entry on the menu widget itself.)

#4 follow-up: @westonruter
4 years ago

Should the widget link should perhaps link to the Widgets panel in the Customizer?

#5 @melchoyce
4 years ago

Depends — not sure knocking them out of the menu creation flow is the right thing here, especially since even if they do want to use a menu widget, they need to make the menu first.

#6 in reply to: ↑ 4 @bpayton
4 years ago

That was my read on it as well. We link to the Widget panel in Menus -> View All Locations, but when creating a menu, I would be looking for additional info on widgets and surprised to be taken to another panel.

#7 @bpayton
4 years ago

  • Keywords has-patch added

Hi @westonruter, I have a patch for this. This is a simpler task, but I'm uncertain whether I handled the combination of i18n and HTML correctly. Are you up for taking a look?

https://github.com/brandonpayton/wordpress-develop/pull/2

#8 @westonruter
4 years ago

  • Owner changed from bpayton to melchoyce
  • Status changed from assigned to reviewing

PR approved. Ready for design review and commit.

#9 @melchoyce
4 years ago

Two things:

  • Can we put "(If you plan to use a menu widget, skip this step.)" onto a new line?
  • I know this isn't a new thing, but the spacing those menu location list items is very high, thanks to the margin-bottom: 12px; on .customize-control. Do you know where that was introduced? The 6px it falls back to is what seems to be used on all the other radio/checkbox lists.

#10 @westonruter
4 years ago

  • Owner changed from melchoyce to bpayton

#11 @bpayton
4 years ago

I pushed an update to put the menu widget note on a new line.

I took a look at the spacing of the location list items and confirmed the issue only affects the new-menu section. The spacing of the checkboxes in edit-menu sections looks just fine (though I did push a commit to add padding between locations and the auto-add-top-level-pages control).

The strange thing is that the edit menu section relies on styles defined in nav-menus.css and a rule for .menu li. The rule(s) apply because we're manually adding the menu class to the content container when a menu section is expanded. This is poor because we're relying on styles defined for menu admin rather than for Customizer. To address the new-menu spacing issue and to reduce the edit-menu reliance on nav-menus.css, I added (and pushed) a rule that explicitly sets item spacing for the new- and edit-menu sections.

@melchoyce, this is ready for another review.

#12 @melchoyce
4 years ago

Thanks @bpayton. Can you add a screenshot?

@bpayton
4 years ago

Edit Menu: Margin is improved for Menu Options

#13 @bpayton
4 years ago

@melchoyce I added a before and after shot for menu create and edit. The left is before, and the right is after.

#14 @melchoyce
4 years ago

  • Keywords commit added
  • Owner changed from bpayton to westonruter

Looks good, let's ship it 👍

#15 @westonruter
4 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 41832:

Customize: Vary description for nav menu locations control based on whether it is shown during menu creation.

Also fix issue with initial visibility of notice when there are no menus.

Amends [41823].
Props bpayton, melchoyce, westonruter.
See #42116.
Fixes #42113.

Note: See TracTickets for help on using tickets.