WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#42219 closed defect (bug) (invalid)

Content inserted after a gallery (wpview) shows before the gallery

Reported by: bduclos Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: TinyMCE Keywords: reporter-feedback
Focuses: javascript Cc:

Description

Bug appears in Chrome since WordPress 4.7.4 and is still happening in Trunk.
Steps to reproduce:

  • start from a brand new page
  • insert a gallery (or any wpview like video or audio)
  • place the cursor to the right of the gallery
  • insert an image (or video/gallery/audio)

Result: the image isn't inserted after the gallery, it appears at the top of the page.

Change History (6)

#1 @subrataemfluence
4 years ago

  • Keywords reporter-feedback added

Hello,
Welcome to trac and thanks for the ticket. I am not sure if I have understood the exact situation correctly. Are you saying something like this?

start from a brand new page
Create a new page in admin

insert a gallery (or any wpview like video or audio)
Add media from gallery by using Add Media button above the visual editor

place the cursor to the right of the gallery
Place the cursor the right of the added media

insert an image (or video/gallery/audio)
Open Media Gallery by clicking Add Media button and add another image (or another media)

If this is not what you are saying, please let me know what exactly I need to do in order to reproduce the issue. Because above steps did not reproduce anything like this. Also it would be nice if you please explain the phrase insert a gallery

My WordPress version: 4.8.2
Browser: Chrome
OS: Ubuntu 14.04 LTS

#2 @bduclos
4 years ago

Hi,

Yes the steps are exactly what you've described. Here's a Gif: (you can see that the image is inserted before the gallery):

https://i.imgur.com/5OCovHk.gif

WordPress versions tested: 4.7.4, 4.8.2, trunk.
Browser: Chrome
OS tested: Windows 10 and Mac OS Sierra 10

#3 @subrataemfluence
4 years ago

Thank you! I will try on Windows environment soon.

On a side note, do you have any third party plugin active? If yes, can you please try once again by first deactivating all of them? Even better if can try on a clean WordPress installation.

#4 @bduclos
4 years ago

The tests are done on a clean WordPress installation, no third party plugin, with TwentySeventeen theme.

#5 @subrataemfluence
4 years ago

Hmm. Is this OS? I have to try on Windows !

#6 @azaozz
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

@bduclos I can't reproduce this either, tested in latest stable FF and Chrome on win10. Perhaps it was fixed with the TinyMCE update in WP 4.9?

Closing as invalid for now, feel free to reopen with more info on how to reproduce if this still happens.

Note: See TracTickets for help on using tickets.