WordPress.org

Make WordPress Core

#42275 closed defect (bug) (fixed)

Customize, Activate and Live Preview button are not aligned properly on themes page under apperance

Reported by: sayedwp Owned by: westonruter
Milestone: 4.9 Priority: normal
Severity: normal Version: 4.9
Component: Themes Keywords: has-patch
Focuses: ui, administration Cc:

Description

https://user-images.githubusercontent.com/6297436/31760082-2632566e-b4d1-11e7-99fb-2d5e4cbe8e50.png

Attachments (2)

42275.diff (455 bytes) - added by Mirucon 22 months ago.
42275.1.diff (11.2 KB) - added by Mahvash Fatima 22 months ago.

Download all attachments as: .zip

Change History (14)

#1 @ocean90
22 months ago

  • Component changed from General to Themes
  • Focuses administration added
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.9

#2 follow-up: @melchoyce
22 months ago

This is a recent regression. Can we track down where it was introduced?

#3 @melchoyce
22 months ago

#42279 was marked as a duplicate.

@Mirucon
22 months ago

#4 @Mirucon
22 months ago

  • Keywords has-patch added; needs-patch removed

Here's my patch from #42279

#5 @sayedwp
22 months ago

This will break the customizer theme's panel buttons because they both share the common css, I think this is regression from #42215 @mahvash-fatima can you take a look

https://user-images.githubusercontent.com/6297436/31767021-43823c46-b4e7-11e7-9c96-55d06efd5aa7.png

#6 @Mahvash Fatima
22 months ago

Ah, I was not aware that the same css is applied in Appearance > Themes as well, working to fix.

BTW the same button vertical alignment issue already exists for themes page as well for small screen.

https://user-images.githubusercontent.com/12367607/31767818-47086cd4-b4ea-11e7-82a3-4b1373269d25.png

#7 in reply to: ↑ 2 @jcastaneda
22 months ago

Replying to melchoyce:

This is a recent regression. Can we track down where it was introduced?

From what I was able to find it was introduced in [41893]

#8 @Mahvash Fatima
22 months ago

About the changes.

1- Moved my CSS added in #42215 in customize-controls.css to themes.css so it can be used at both the places.
2 - Added some css for button for bigger screen.
3- Add wrapper div around the theme action elements so its properly structured, and easy to align. ( No other changes in the markup ) just the way it was done in #42215

#9 @melchoyce
22 months ago

Looks like that fixed it, thanks @Mahvash Fatima 👍

@westonruter would you mind giving it a quick review?

#10 @melchoyce
22 months ago

  • Owner set to westonruter
  • Status changed from new to assigned

This ticket was mentioned in Slack in #core-customize by sayedwp. View the logs.


22 months ago

#12 @westonruter
22 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 41949:

Customize: Fix alignment of Customize, Activate, and Live Preview buttons appearing on the Themes admin screen.

Amends [41893].
Props Mahvash-Fatima.
See #42215.
Fixes #42275.

Note: See TracTickets for help on using tickets.