WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#42302 closed defect (bug) (fixed)

Gallery-Widget Shows Differing Hover-Behaviours In Different Locations

Reported by: transl8or Owned by: davidakennedy
Milestone: 4.9 Priority: normal
Severity: normal Version: 4.9
Component: Bundled Theme Keywords: has-patch commit
Focuses: ui Cc:
PR Number:

Description

I'm not sure if this is a bug in Twenty Seventeen or meant to be by design.

After creating 3 galleries the same way with the new Gallery-Widget (6 pictures, 3 in a row, thumbnail view, linked to media file) and placing them in 3 differnt locations in Twenty Seventeen (Sidebar, Footer One, Footer Two) they all appear a little different in size and hover-style.

Especially when placed in the footer area the pictures show a small 3 pixel frame at the bottom when hovering over one. Thats not the case when a gallery is placed in the sidebar.

Also the picture size of a gallery differs a lot between footer one and footer two in Twenty Seventeen.
Is this meant to be that way?

As said, I created 3 galleries with the new widget the same way: same pictures, same order, thumbnails, linked to, etc. ...

Test enviroment: Windows with latest Firefox 56.x.

Attachments (2)

WordPress49-GallerWidget-beta3-with-TwentySeventeen.jpg (100.7 KB) - added by transl8or 2 years ago.
Gallery-Widgets in Twenty Seventeen
42302.1.patch (549 bytes) - added by davidakennedy 2 years ago.
Update gallery link selectors to make sure they're consistent in widget areas with main content area.

Download all attachments as: .zip

Change History (10)

@transl8or
2 years ago

Gallery-Widgets in Twenty Seventeen

#1 @melchoyce
2 years ago

  • Owner set to davidakennedy
  • Status changed from new to assigned

#2 @melchoyce
2 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.9

#3 @sami.keijonen
2 years ago

Thanks @transl8or for report.

Also the picture size of a gallery differs a lot between footer one and footer two in Twenty Seventeen.

Is this meant to be that way?

That seems to be how it suppose to be. Gallery images take the space they have (33% in this case) and Footer 2 is wider than Footer 1. Therefore there are more room to images also.

Especially when placed in the footer area the pictures show a small 3 pixel frame at the bottom when hovering over one. Thats not the case when a gallery is placed in the sidebar.

I agree that there should be same design on hover&focus. In site footer there is stronger CSS (box-shadow) applied to all links, including gallery links.

I'd say gallery links should not have border bottom (box-shadow) in Footer, and should have same design as in main sidebar.

@melchoyce That's more your call though:) What say you?


This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


2 years ago

@davidakennedy
2 years ago

Update gallery link selectors to make sure they're consistent in widget areas with main content area.

#5 @davidakennedy
2 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

Nice find @transl8or!

As far as the design goes, that's correct. @sami.keijonen is correct in that those widget areas have a different width, so the appearance will be vary slightly.

I agree that the links should act the same way. The regular gallery link styles were being overridden by more specific styles. My latest patch should address that. Would love someone to test before I commit.

#6 follow-up: @sami.keijonen
2 years ago

Tested the patch and confirm that hover/focus styles are now same also in widget areas. Which means without box-shadow.

#7 in reply to: ↑ 6 @melchoyce
2 years ago

  • Keywords commit added; needs-testing removed

Replying to sami.keijonen:

Tested the patch and confirm that hover/focus styles are now same also in widget areas. Which means without box-shadow.

Thanks for testing. I agree re: no box-shadow. 👍

#8 @davidakennedy
2 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 42004:

Twenty Seventeen: Make gallery link styles consistent in all widget areas

Removes the box shadow on gallery links in footer widget areas so they're consistent with the sidebar widget area.

Props transl8or, sami.keijonen, davidakennedy.

Fixes #42302.

Note: See TracTickets for help on using tickets.