WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 19 months ago

#42338 closed defect (bug) (invalid)

Blank page on plugin-install.php

Reported by: theyrobburnfield Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.2
Component: Plugins Keywords:
Focuses: Cc:

Description

I'm running into an issue on /wp-admin/plugin-install.php where the page is just blank.
After some investigating it would appear the issue is related to the plugin icon being an svg.

When I use inspector to replace the svg with a png or jpg instead the page properly loads everything. But put a png in there and everything goes blank. Noticed the svg was being loaded by the popular Jetpack plugin and so my install plugins page is blank.

See code line 537 of the file /wp-admin/includes/class-wp-plugin-install-list-table.php for where the image is output.

I'm guessing the reason for the issue is that svg don't have a normal calculated height/width and so the container is just expanding way outside of the image container itself. Maybe try wrapping the img tag in a div and setting the width and height on that container as well to keep the image from bleeding outside if it is an svg.

Change History (10)

#1 @westonruter
3 years ago

  • Keywords reporter-feedback added

@theyrobburnfield What browser are you using? I cannot reproduce this issue.

#2 @theyrobburnfield
3 years ago

@westonruter

Mac OS Sierra 10.12.6
Chrome Version 61.0.3163.100 (Official Build) (64-bit)

Last edited 3 years ago by theyrobburnfield (previous) (diff)

#3 @subrataemfluence
3 years ago

@theyrobburnfield , I am not familiar with Mac systems. But can you please do a bit of cross examinations like following?

  1. Is this happening for you in other Mac based browsers too?
  2. If yes, can you please double check if it is happening in other OS like Linux or Windows?
  3. Can you please deactivate all your plugins and see if you still encounter the same problem?
  4. Are you able to reproduce the issue on a clean WordPress install using Mac OS Sierra?

If you haven't already done the above tests, it would be nice if you please do them. I tried to reproduce the issue in FireFox and Chrome in both Ubuntu and Windows and IE Edge on Windows but could not reproduce the issue.

One more thing, now-a-days a large number of plugins are using SVG icons and of course a large number of people are using Mac systems. So my personal feeling is this could be something related to your browser or its configuration.

#4 @theyrobburnfield
3 years ago

@subrataemfluence

Okay after a little bit of digging it appears to only be with chrome. Safari/Firefox loads just fine.
I also am on a base install, no plugins, that twenty-something theme that comes standard.

#5 @subrataemfluence
3 years ago

Thanks. I am on Chrome Version 62.0.3202.62 (Official Build) (64-bit) on Ubuntu Linux. Could there be any possibility that your Chrome has got some issues? Is this possible that you uninstall and reinstall it and then do another test?

#6 @johnbillion
3 years ago

You should try deactivating your Chrome extensions too, in order to see if one of them is the cause of the problem.

#7 @theyrobburnfield
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Well uninstalled plugins/extensions got fresh chrome still happening. But restart my computer and bam problem gone. Now I feel like slamming my head against a wall for an hour or so. Sorry for wasting peoples time.

#8 @SergeyBiryukov
3 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

#9 @cyberkishor
2 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi,

I have same problem but there is some notice : Undefined property: stdClass::$plugins in wp-admin/includes/class-wp-plugin-install-list-table.php line 232

and also Notice: : Undefined property: stdClass::$info in wp-admin/includes/class-wp-plugin-install-list-table.php line 239

I think we have to fix it.

Thanks

#10 @earnjam
19 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

@cyberkishor Yours sounds like a different issue. It's been a while since you posted this, but if you're still seeing this problem can you open a separate ticket with more information? In your case, I suspect a plugin has added a filter to plugins_api_result and has mangled the response.

Note: See TracTickets for help on using tickets.