WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 2 years ago

#42349 closed defect (bug) (worksforme)

Things get deleted when editing anchor text on lins

Reported by: anormal Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: reporter-feedback
Focuses: performance Cc:

Description

So if I set a link, and then want to change that blue text from the text editor (as opposed to clicking the pencil button and editing the whole thing on the link editor pop up), I set the cursor on the anchor word that I want to change and type backspace and suddenly the whole paragraph and previous image is deleted. The same thing happens when using Delete.

Not only is this not useful and annoying but it's retarded. I get the fact that maybe you have to click on the pencil icon to edit the whole URL and anchor text, but why does the whole paragraph and surrounding objects have to disappear?

Change History (2)

#1 @azaozz
4 years ago

  • Keywords reporter-feedback added

Can't reproduce this, editing a link's text works properly. Pressing delete/backspace on the last letter removes the link.

Can you provide some more info please:

  • What version of WordPress.
  • What browser are you using.
  • Try this in a private window in the browser (to run without any browser add-ons/extensions).

If still the same, try it with all WordPress plugins disabled and a default theme. If still happens, are there any errors in the browser console?

#2 @pento
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket, as we're unable to reproduce this issue without more
information.

Note: See TracTickets for help on using tickets.