WordPress.org

Make WordPress Core

Opened 8 months ago

Last modified 7 months ago

#42356 new defect (bug)

No Media in Grid View & No Upload possible

Reported by: smark87 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.8.2
Component: Media Keywords: reporter-feedback
Focuses: administration Cc:

Description

Problem Description: Grid View in Media Library Show only one empty thumbnail & upload does not work

in my network console I see that the admin-ajax.php is endless running

In the List view I'm able to see all files & when I search für media files I see also the correct result

What I tried to solve the Problem:

  • increase memory limit
  • check wordpress debug mode
  • check php errorlog files
  • set reverse uploads dir permissions to 775 & file permissions to 644
  • deactivate all plugins
  • change custome template to a wordpress default one
  • set upload path & upload url path in den database
  • check if a further bugfix is really fixed in my version (https://core.trac.wordpress.org/changeset/30259)

But I have no more idea now :-/

Attachments (5)

Bildschirmfoto 2017-10-27 um 14.29.53.png (154.2 KB) - added by smark87 8 months ago.
endless file load
Bildschirmfoto 2017-10-27 um 14.31.19.png (17.7 KB) - added by smark87 8 months ago.
empty media lib
headers.png (198.5 KB) - added by smark87 8 months ago.
headers
preview.png (144.5 KB) - added by smark87 8 months ago.
preview
Bildschirmfoto 2017-11-02 um 17.09.57.png (86.7 KB) - added by smark87 8 months ago.
List View Problem

Download all attachments as: .zip

Change History (15)

@smark87
8 months ago

endless file load

#1 follow-up: @adamsilverstein
8 months ago

Hi @smark87 and thanks for the bug report.

To clarify, you already have media in your library or is this a fresh install? Does the media list view work correctly?

Can you try disabling all plugins and using a default theme to see if the problem persists?

#2 in reply to: ↑ 1 @smark87
8 months ago

Hi @adamsilverstein.

I already have media in the library. The website is some years old now. The list view work correct.

I already try disabling all plugins and using a default theme. But it does not helped

#3 follow-up: @adamsilverstein
8 months ago

Ok, thanks for the details, I'll try to reproduce locally.

Can you click on the ajax request in your console and screenshot the (network tab) headers and preview tabs. Specifically want to know what request is being sent and the response. Do you know when the issue started happening? What browser/version/platform are you on?

#4 @joemcgill
8 months ago

Possibly related to [41937] (edit: if this is trunk, but that shouldn't affect 4.8.2).

@smark87 do you have any other plugins running that affect the media library or is this reproducible for you with plugins deactivated, and a default theme active?

Last edited 8 months ago by joemcgill (previous) (diff)

#5 in reply to: ↑ 3 @smark87
8 months ago

Hi @adamsilverstein, network headers and preview attached (I needed to hide some privacy infos, but there no special char in the names or something like that...)

the issue happens direct when i open the media library page

I use chrome 62, firefox 56, safari 91 on a osx yosemite. All browser the same error. I think it might be a database or script problem

@smark87
8 months ago

headers

@smark87
8 months ago

preview

#6 @adamsilverstein
8 months ago

@smark87 thanks for the details. Do you see any JavaScript errors in the console? Does each subsequent request show a higher query[paged] (these should increment) - it looks like the media is being requested and never displayed. can you try removing the first item from your library using the list view?

https://cl.ly/2x2w1i023x3v/Media_Library__Five_Thirty_Eight__WordPress_2017-10-27_10-54-33.jpg

#7 @smark87
8 months ago

Hi @adamsilverstein , there are no Javascript errors in the console. The query[paged] is everytime the same. I can't remove the first items from the library in the list view. I think here could be the issue see the attached screenshot

@smark87
8 months ago

List View Problem

#8 @joemcgill
8 months ago

FWIW, I've seen this happen myself if the media query fails to return the expected number of attachments. This usually is caused by either a plugin filtering out attachments before they're returned inside of wp_ajax_query_attachments() or if wp_prepare_attachment_for_js() returns void for a post for some reason.

@smark87 can you ensure that this is reproducible with plugins deactivated and a default theme installed?

This ticket was mentioned in Slack in #core-media by desrosj. View the logs.


7 months ago

#10 @joemcgill
7 months ago

  • Keywords reporter-feedback added
Note: See TracTickets for help on using tickets.