WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 14 months ago

#42410 closed defect (bug) (duplicate)

wpautop() breaks HTML (missing start tag p)

Reported by: mar1in Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: Formatting Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Create new page with the following content:
    <ul>
    <li>Text
    <!-- Comment -->
    <ol></ol></li>
    </ul>
    
  2. Preview post and inspect HTML output

Expected result:

<ul>
<li>Text<br />
<!-- Comment -->
<ol></ol>
</li>
</ul>

Actual result:

<ul>
<li>Text<br />
<!-- Comment --></p>
<ol></ol>
</li>
</ul>

Change History (1)

#1 @pento
14 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27350.

Note: See TracTickets for help on using tickets.