WordPress.org

Make WordPress Core

#42415 closed defect (bug) (fixed)

Customize: changeset_uuid does not get stripped from URL after activating theme

Reported by: westonruter Owned by: westonruter
Milestone: 4.9 Priority: low
Severity: normal Version: 4.9
Component: Customize Keywords: has-patch commit dev-reviewed
Focuses: Cc:

Description

Steps to reproduce:

  1. Open customizer.
  2. Switch to a different theme.
  3. Notice that the changeset_uuid query parameter is in the URL.
  4. Hit “Activate & Publish”
  5. Notice the changeset_uuid query parameter is still in the URL.
  6. Reload the page and see an error about the changeset already being published.

The changeset_uuid needs to be stripped from the URL regardless of whether or not branching mode is enabled upon publishing because a published changeset cannot be further edited.

Attachments (3)

42415.0.diff (965 bytes) - added by westonruter 23 months ago.
42415.1.diff (1.3 KB) - added by westonruter 23 months ago.
42415.2.diff (1.3 KB) - added by westonruter 23 months ago.

Download all attachments as: .zip

Change History (12)

#1 @westonruter
23 months ago

  • Keywords has-patch needs-testing added

#2 @westonruter
23 months ago

  • Owner set to westonruter
  • Status changed from new to accepted

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


23 months ago

This ticket was mentioned in Slack in #core-customize by westonruter. View the logs.


23 months ago

#5 @bpayton
23 months ago

It took me a moment to process the if/else, and I'm wondering whether the following would be clearer:

populateChangesetUuidParam( api.settings.changeset.branching && shouldInclude )

This ticket was mentioned in Slack in #core-customize by bpayton. View the logs.


23 months ago

#7 @westonruter
23 months ago

  • Keywords dev-feedback added; needs-testing removed

#8 @obenland
23 months ago

  • Keywords commit dev-reviewed added; dev-feedback removed

42415.2.diff LGTM 👍

#9 @westonruter
23 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 42114:

Customize: Ensure changeset_uuid param for autosave auto-draft gets stripped from location after previewing theme switch when not in branching mode.

Amends [41597].
See #39896.
Fixes #42415.

Note: See TracTickets for help on using tickets.