WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 6 months ago

#42432 closed feature request (wontfix)

Upload image without creating intermediate sizes

Reported by: web2033 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: reporter-feedback close
Focuses: administration Cc:

Description (last modified by mikeschroder)

Sometimes we know exactly that uploaded image don't need to be resized.
Maybe checkbox - "upload without creating image sizes".

Change History (5)

#1 @mikeschroder
3 years ago

  • Keywords reporter-feedback added
  • Type changed from feature request to defect (bug)

Hi! Thanks for the report, and apologies for the delay in a reply.

The default action for uploads in posts and the media library doesn't include cropping, so I suspect you're probably running into a problem with one of the Customizer or Appearance upload/cropping flows.

Could you please walk me through the steps you're taking, and which case you're running into where it always asks for a crop?

Thanks much!

#2 @web2033
3 years ago

  • Type changed from defect (bug) to feature request

Hi! It was meant to be "resizing" (creating additional sizes) instead of "cropping".
So it's not a bug report. Rather a feature for disabling resizing in certain situations.

#3 @mikeschroder
3 years ago

  • Description modified (diff)
  • Summary changed from Upload image without cropping to Upload image without creating intermediate sizes

I went ahead and edited the ticket to reflect what you explained. Please let me know if I got anything wrong.

Can you please walk me through some use cases where you wouldn't want other sizes created?

Generally, WordPress leans towards fewer options rather than more (see Decisions not Options), so I'd love to understand more about why you think this one should be included.

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


6 months ago

#5 @antpb
6 months ago

  • Keywords close added
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

It was discussed in the recent Media component bug scrub that this would likely not be feasible given the amount of tickets and focuses in Media. This is a big change to how media is handled in WordPress. It would need to consider the server limitations, etc before this could move forward.

It was also mentioned that some plugins achieve this already such as: https://wordpress.org/plugins/dynamic-image-resizer/

We're going to close this to keep our focus on a more accurate list of Media tickets, but if anyone feels strongly about this change, feel free to comment below! :D

Note: See TracTickets for help on using tickets.