WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 19 months ago

#42444 closed defect (bug) (worksforme)

Quotes in post title are not searched correctly when on mobile

Reported by: mikejolley Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Reported in https://github.com/woocommerce/woocommerce/issues/17564 but affects all post types.

To reproduce the issue:

  1. Create a post with a quote in the title e.g. "Hello World Y'all" using desktop browser.
  2. Search for "Y'all" in desktop browser. Results found.
  3. Search for "Y'all" on mobile (I used xcode simulator to simulate iPhone). No results.

Looks like some kind of weird encoding bug.

Change History (1)

#1 @andraganescu
19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This happens only in the simulator because the simulator replaces the quote sign with the a "smart" quote. While using the actual device it worked all right.

Note: See TracTickets for help on using tickets.