WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 5 weeks ago

#42496 closed feature request (duplicate)

Add CSSTidy in WP

Reported by: tazotodua Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

On | Add Inline CSS page, there is said, that best thing to filter inline css is to use CSS-Tidy.
Why not WP automatically include the sanitization for <code>wp_add_inline_style</code>?
I think, it could be useful, yeah?

Change History (2)

This ticket was mentioned in Slack in #core by markparnell. View the logs.


5 weeks ago

#2 @peterwilsoncc
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @tazotodua and I'm sorry it's taken so long for this ticket to be replied to.

Including CSSTidy was discussed extensively in #35395 as part of a more general ticket on the subject of providing a CSS sanitization function. It was decided against for a number of reasons.

I'll close this as a duplicate of the earlier ticket.

Note: See TracTickets for help on using tickets.