WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#42499 closed defect (bug) (worksforme)

Customizer Broke, says You are customizing Beta Wordpress

Reported by: xllentech Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Customize Keywords:
Focuses: Cc:
PR Number:

Description

I updated to Wordpress WordPress 4.9-RC2-42139 from 4.8.3

When I updated, update process worked fine. but after the update, I went to Appearance-> Customize ..and it just says "You are customizing" in small letters and below it says "Beta Wordpress". and the rest of the whole screen is blank as in screenshot.

BTW, I am using InstantWP for beta purpose, not sure if that makes any difference. I have had no other issues till date for over a year.

Let me know if you need more information.

Attachments (1)

4.9-RC2-42139-beta-error.jpg (42.6 KB) - added by xllentech 2 years ago.
Customizer Screenshot

Download all attachments as: .zip

Change History (7)

@xllentech
2 years ago

Customizer Screenshot

#1 @westonruter
2 years ago

@xllentech Hi, what plugins and theme do you have active?

Is there an error appearing in your PHP error log? It seems like you may be having a PHP fatal error.

#2 @westonruter
2 years ago

  • Keywords reporter-feedback added

#3 @westonruter
2 years ago

Please also look at your browser's JavaScript console to see if there are errors there.

#4 @xllentech
2 years ago

I am using Total theme, paid theme from themeforest.

I had deactivated all plugins, still the same issue. I have 9 plugins active..

Contact Form 7

Slider Revolution

Templatera

WordPress Beta Tester

WPBakery Page Builder

XllenTech Calendar Pro ADD-ON (Self-developed)

XllenTech English Islamic Calendar (Self-developed)

Xllentech Salat Timings (Self-developed)

XllenTech Upcoming Events (Self-developed)

Javascript error tha comes up in Devtools in Chrome is as below:

Uncaught TypeError: Cannot set property 'parent' of undefined

at Function.add (customize-base.min.js:1)
at Object.<anonymous> (customize-controls.min.js:3)
at Function.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,shortcode,utils,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9-RC2-42139:2)
at HTMLDocument.<anonymous> (customize-controls.min.js:3)
at i (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,shortcode,utils,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9-RC2-42139:2)
at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,shortcode,utils,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9-RC2-42139:2)
at Function.ready (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,shortcode,utils,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9-RC2-42139:2)
at HTMLDocument.K (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,shortcode,utils,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=4.9-RC2-42139:2)

#5 @westonruter
2 years ago

@xllentech could you please add the following to your wp-config.php:

define( 'SCRIPT_DEBUG', true );
define( 'WP_DEBUG', true );

This will allow you to more easily see what the error is.

Additionally/alternatively, if you could send a ZIP of all your active themes and plugins to trac-wp-core-42499@xwp.co I will then be able to test locally on my environment.

#6 @westonruter
2 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I tried to reproduce the problem with the themes and plugins but I was unable. As we discussed over email, please share if you encounter the cause and there is a core defect to fix.

Note: See TracTickets for help on using tickets.