WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#42507 closed defect (bug) (duplicate)

Custom wp_queries being broken in 4.8.3

Reported by: stefk Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.3
Component: Query Keywords:
Focuses: Cc:

Description

Support has been dropped in Wordpress 4.8.3 for custom meta keys that make use of the LIKE element.

Custom wp_queries being broken when using meta_query combined with the repeater format of for custom fields. They ended up returning 0 results.

For example below stopped working:

$meta_query_1[0] = array(

array(

'key' => 'price_section_%_departure_date',
'compare' => '>',
'value' => 0,
'type' => 'NUMERIC'

)

);

Change History (2)

#1 @birgire
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #42409.

#2 @Clorith
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.