WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#42523 closed enhancement (duplicate)

Stop fatal errors when installing a new theme

Reported by: hardeepasrani Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords:
Focuses: administration Cc:

Description

We've added linting which will stop people from causing fatal errors when editing a theme but can we do something similar when they install the theme?

When someone activates a plugin with a fatal error, it stops and deactivates. We can have something similar for the themes?

You activate it > There's a fatal error > Don't activate the theme.

What do you think?

Change History (2)

#1 @westonruter
4 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

Agreed. The same sandboxing logic used when editing themes or plugins should also be used when activating (or upgrading) a theme or plugin.

#2 @swissspidy
4 years ago

  • Component changed from Upgrade/Install to Themes
  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #12839.

Note: See TracTickets for help on using tickets.