WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 13 months ago

#42541 closed defect (bug) (invalid)

WordPress HTTP Error When Publishing New Article

Reported by: iskybird Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.3
Component: General Keywords:
Focuses: Cc:

Description (last modified by talldanwp)

Well I have wordpress multi-site, one is on sub-domain.example.com and the other is on example.com/sub-folder.

It's been going quite good! But suddenly I faced this problem today! The sub-domain wordpress is fine. But when today I was trying to publish an article on the sub-folder, it said HTTP Error and didn't publish the article neither did it save it as draft. To check whether the problem is on my server or wordpress, I quickly went to the sub-domain wordpress and tried to publish another article over there, but it didn't cause any problem. My WordPress Memory limits are 96MB on both sites and max limit is 256M on both sites.

What I must mention is when this error is given, the other wordpress site is also unavailable for a few seconds. And then both sites are back up and working.

Also Note that I can edit previous articles and update them without any error. This problem is only happening in new article publishing time.

The problems I was facing previously but didn't take any action because I thought the work is going on so let's not bother about it is, on the sub-folder site (current site which has current problem) used to show 500 Internal Server Error whenever I published new article, the site stayed down for a couple of minutes and then when it is up and running, the new article was published! So when I saw that I found my articles published, I didn't bother to do anything about it. But now I have no other choice but to fix it.

Attachments (1)

Capture.PNG (8.8 KB) - added by iskybird 4 years ago.

Download all attachments as: .zip

Change History (3)

@iskybird
4 years ago

This ticket was mentioned in Slack in #core by noisysocks. View the logs.


13 months ago

#2 @talldanwp
13 months ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Summary changed from Wordpress HTTP Error When Publishing New Article to WordPress HTTP Error When Publishing New Article

Hi @iskybird, apologies it's taken a little while to get a response.

I realise you may have solved the issue in the last 3 years. For these kind of issues, I'd recommend reaching out on the support forums for help - https://wordpress.org/support/forum/how-to-and-troubleshooting/.

The difficulty with creating a ticket here is that this isn't really a bug reproducible outside of your site. As such I'll close this ticket.

Note: See TracTickets for help on using tickets.