WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 23 months ago

Last modified 23 months ago

#42561 closed defect (bug) (wontfix)

No scrolling and selected word stays out of view when switching between Visual and Text modes

Reported by: afercia Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Editor Keywords:
Focuses: accessibility, administration Cc:

Description

The fix from #42530 (specifically 42184) doesn't seem to work properly, and it behaves inconsistently across browsers. To reproduce:

  • Uncheck "Enable full-height editor and distraction-free functionality." in the Screen options
  • using Chrome, edit a long post starting in the "Visual mode"
  • select a word that occurs at about the middle of the post content:

https://cldup.com/tPgw-6wpIk.png

  • switch to "Text mode": no scrolling happens and the selected word stays out of view:

https://cldup.com/XovMqyzv1V.png

  • switch back to "Visual mode"
  • the selected word is almost completely hidden at the top of the content visible area:

https://cldup.com/gitpyBHrYM.png

Using Firefox instead, it behaves a bit better: at least the selected word is visible when switching from VIsual to text:

https://cldup.com/x4UiZEBviz.png

See also #42553.

Change History (23)

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


3 years ago

#2 @johnbillion
3 years ago

  • Milestone changed from 4.9.1 to 4.9.2

#3 @obenland
3 years ago

  • Owner set to pento
  • Status changed from new to assigned

#4 @dd32
3 years ago

  • Milestone changed from 4.9.2 to 4.9.3

Bumping to 4.9.3 due to 4.9.2s release

This ticket was mentioned in Slack in #core by desrosj. View the logs.


3 years ago

#6 @SergeyBiryukov
3 years ago

  • Milestone changed from 4.9.3 to 4.9.4

#7 @dd32
3 years ago

  • Milestone changed from 4.9.4 to 4.9.5

Bumping, 4.9.4 has been released.

#8 @audrasjb
2 years ago

Hello,
As far as I know, it still needs a patch before landing in the next minor.

4.9.5 beta release is planned for next Tuesday so we'll need a patch in the next few days otherwise it will be punted to 4.9.6 (which is not that bad).

#9 @audrasjb
2 years ago

  • Milestone changed from 4.9.5 to 4.9.6

Bumping to 4.9.6 due to 4.9.5 beta release.

#10 @pento
2 years ago

  • Owner pento deleted

This ticket was mentioned in Slack in #core by desrosj. View the logs.


2 years ago

This ticket was mentioned in Slack in #core by desrosj. View the logs.


2 years ago

This ticket was mentioned in Slack in #core by desrosj. View the logs.


2 years ago

This ticket was mentioned in Slack in #core by desrosj. View the logs.


2 years ago

#15 @desrosj
2 years ago

  • Milestone changed from 4.9.6 to 4.9.7

No patch here. Punting to 4.9.7.

#16 @desrosj
2 years ago

  • Milestone changed from 4.9.7 to 4.9.8

Moving all tickets in 4.9.7 to 4.9.8.

#17 @pento
2 years ago

  • Milestone changed from 4.9.8 to Future Release

Ticket needs an owner.

This ticket was mentioned in Slack in #core by pbiron. View the logs.


2 years ago

#19 @afercia
23 months ago

Just tested again and it still happens on current trunk.

  • Chrome: works only when "Enable full-height editor and distraction-free functionality" is enabled
  • Firefox: works only when switching back to Visual and only if "Enable full-height editor and distraction-free functionality" is enabled

Haven't tested other browsers. In its current state this feature, which is nice to have, works only for some users. I'm afraid I can't help so much here, it would need someone with some good expertise in TinyMCE and the selection API. Or maybe, just accept it works only with "Enable full-height editor and distraction-free functionality" and close this ticket.

/Cc @azaozz

#20 @azaozz
23 months ago

Or maybe, just accept it works only with "Enable full-height editor and distraction-free functionality" and close this ticket.

I'm thinking the same... Had a look there but couldn't pinpoint the problem. This will go away when core is upgraded to use Gutenberg :)

#21 @afercia
23 months ago

Yep, we shouldn't forget there will be users who will keep using the Classic Editor though :) No strong objections to close it.

#22 @azaozz
23 months ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from assigned to closed

OK, closing as wontfix for now. If we look again at that script at some point, I'm sure we will fix this inconsistency too.

This ticket was mentioned in Slack in #accessibility by rianrietveld. View the logs.


23 months ago

Note: See TracTickets for help on using tickets.