WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#42584 closed feature request (duplicate)

Plugins per customized & drafted theme

Reported by: johnjamesjacoby Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Customize Keywords:
Focuses: administration Cc:

Description

Now that Customizer Drafts are possible (#39896) in 4.9 it might be neat to allow plugins to be toggled on & off during the drafting process.

Put another way, when picking a new theme, it's pretty common to need to turn old plugins off and new ones on. Users wouldn't want those toggles to actually happen until the new theme goes live, but we would want to see what the site looks like with the right code in place.

I'm imagining it looking like a regular list control object, but one that allows for fancy & sandboxed live de/activation. (Something like React would help a lot for the magic of it all, but you don't have to take my word for it.)

Change History (2)

#1 follow-up: @westonruter
4 years ago

  • Keywords reporter-feedback added

I think this is a duplicate of #40451.

#2 in reply to: ↑ 1 @johnjamesjacoby
4 years ago

  • Keywords 2nd-opinion reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Replying to westonruter:

I think this is a duplicate of #40451.

Yep. Search failed me because these terms returned a thousand irrelevant results.

Thanks for linking these.

Note: See TracTickets for help on using tickets.