WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#42585 closed defect (bug) (invalid)

trac issue not shown if there is an invisble no-break space

Reported by: thekt12 Owned by:
Milestone: Priority: lowest
Severity: normal Version:
Component: WordPress.org Site Keywords: close
Focuses: Cc:

Description

I spotted this issue when I was redirected from LinkedIn and the trac URL contained a No-Break space appended to the end of the actual URL. This is not visible in chrome unless you open the Network and start inspecting the request made.

I have faced a similar issue whit Whatsapp also.
I know I should be contacting them and saying fix your system. but it would be great if we can trim the invisible no breaking character from the page id before processing it.

Attachments (1)

wordpress trac issue.png (120.7 KB) - added by thekt12 4 years ago.
Image to support this

Download all attachments as: .zip

Change History (4)

@thekt12
4 years ago

Image to support this

#1 @thekt12
4 years ago

  • Summary changed from trac issue not shown if there is an invisble to trac issue not shown if there is an invisble no-break space

#2 @swissspidy
4 years ago

  • Keywords close added
  • Priority changed from normal to lowest

I think this should be reported to https://trac.edgewall.org/ or meta.trac.wordpress.org if anything.

#3 @SergeyBiryukov
4 years ago

  • Component changed from General to WordPress.org site
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Yes, please report this upstream at https://trac.edgewall.org/.

Note: See TracTickets for help on using tickets.