WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#42590 closed defect (bug) (duplicate)

Failure to update Plugins

Reported by: showcasedan Owned by:
Milestone: Priority: normal
Severity: major Version: 4.9
Component: Plugins Keywords:
Focuses: Cc:

Description

Hello,

We have numerous customers who have recently updated to WP 4.9. Since that update, they are UNABLE TO UPDATE OUR PLUGIN (we have an IDX plugin for wordpress). When trying to update to OUR latest version of our plugin, users are greeted with the following error on the admin dashboard-Plugins page:

Update Failed: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.

We have confirmed this does NOT happen with our customers running WP 4.8.3 or earlier

Change History (10)

#1 @Ipstenu
3 years ago

Is this plugin hosted on WordPress.org?

I'm GUESSING this is related to https://core.trac.wordpress.org/changeset/42011 so you should check if your zip has some disallowed characters?

Last edited 3 years ago by Ipstenu (previous) (diff)

#2 @showcasedan
3 years ago

  • Severity changed from normal to major

Hey @Ipstenu ,

Had the devs follow up with that link you suggested, but that doesn't appear to be the culprit. Any other ideas? Is there any other information I can provide to shed some light on this?

One of the devs asked if it could be related to this similar issue from 2014: https://aaronjholbrook.com/wordpress-permissions-update-error-resolved/

#3 @dd32
3 years ago

Hey @showcasedan

As far as I know, nothing was changed in 4.9 specifically related to plugin updates.
Does the error output include the filename of the file(s) that it's failed to copy? The error you've run into is specifically checking to see if it can write to the filesystem / or the files being modified.

Does your plugin include a custom WP_Upgrader class for the upgrade?
Can you, on the same site, downgrade to 4.8.3 and have the upgrade succeed?
Can you install other plugins? upgrade other plugins? themes?

How were the 4.9 updates completed? Are they on the same hosting platform? Something we've seen in the past is that the WordPress files end up being owned by the incorrect users when the upgrade is performed by the system, resulting in plugin files being unmodifiable.

Unfortunately this is likely a case where you'll have to debug a problematic site and trace the error down, so that we can reproduce the issue.

#4 @showcasedan
3 years ago

Hey @dd32 let me run down the answers I can give you now, and I'll consult with the devs tomorrow to answer the ones I can't answer myself:

Does the error output include the filename of the file(s) that it's failed to copy?
No it does not. I pasted the full error report in my original post.

Can you, on the same site, downgrade to 4.8.3 and have the upgrade succeed?
Yes, there was no issue updating to the latest version of our plugin on the same site running 4.8.3. We also tested on a few other sites using both 4.8.3 and 4.9 and had similar results.

Can you install other plugins? upgrade other plugins? themes?
We were able to update other plugins just fine, although their complexity may be minimal compared to our IDX plugin. I can get further info about which plugins were tested.

I'll update this ticket tomorrow after speaking with thhe client and our devs again.

#5 @dd32
3 years ago

@showcasedan Thanks!
If you'd like me to review your zip, please feel free to send a copy over to dion@wordpress.org and I'll see if there's anything obviously incorrect / incompatible with WordPress / check if it works with my local 4.9 installs / etc.

#6 @jmdarts007
3 years ago

Thanks

#7 @showcasedan
3 years ago

@dd32 Really appreciate the help! I am sending you the zip file now.

We use subversion to push updates to a hosted repo:, if that makes a difference. I'll send you the link in the email.

#8 @showcasedan
3 years ago

Just wanted to check if there was any update to this?

#9 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

My apologies for the delay in response here. It turns out that this is caused by #42628 - which will be fixed in 4.9.1

The plugin in question has folder names of 2/ and 3/ in it, which caused the problem.

#10 @showcasedan
3 years ago

Great, thanks so much for your help! We'll rollback our customers to 4.8.3 for now. Thanks for everything you do!

Note: See TracTickets for help on using tickets.