WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#42591 closed defect (bug) (duplicate)

Wordpress doesn't load template files

Reported by: Vishnja1 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Themes Keywords:
Focuses: template Cc:

Description

It's seems there is an awrful bug in new WP. WP doesn't see new template files created in theme. I made sure that all requirements are OK ('index.php', 'styles.css' etc.) and swithced between themes. I can reproduce this behaviour on new installation of 3.9. And double checked on 3.8.1 everything is fine. Problem is: after grabbing new template file (e.g. 'template-page-contacts'), WP stops loading new templates (e.g. 'template-page-something-else'). And after renaming template some template warnings appear in admin in 'Page Attributes' section: Warning: file_get_contents(D:\OpenServer\domains\wp\test_49/wp-content/themes/briz/archive.php): failed to open stream: No such file or directory in

Change History (4)

#1 @leobaiano
6 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #42573.

#2 @SergeyBiryukov
6 months ago

  • Component changed from General to Themes
  • Focuses accessibility removed

Hi @Vishnja1, welcome to WordPress Trac! Thanks for the report.

As noted above, we're already tracking this issue in #42573.

#3 @SergeyBiryukov
6 months ago

  • Milestone Awaiting Review deleted

#4 @okegima
6 months ago

look like same issue. i removed a page with /* Template Name: Blog */ and now in page attribute i have the following message error :

Warning: file_get_contents(D:\wamp64\www\www.-.fr/wp-content/themes/abeilles/cart.php): failed to open stream: No such file or directory in D:\wamp64\www\www.-.fr\wp-includes\class-wp-theme.php on line 1042

Note: See TracTickets for help on using tickets.