WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4264 closed defect (bug) (fixed)

IE7, available widget drop zone won't expand past 2 rows of available widgets

Reported by: Denis-de-Bernardy Owned by: andy
Milestone: 2.2.1 Priority: high
Severity: major Version: 2.2
Component: Administration Keywords:
Focuses: Cc:

Description

Per Matt's request:

http://trac.wordpress.org/ticket/4259#comment:1

Please see the attached screenshot

Attachments (4)

widgets.png (67.7 KB) - added by Denis-de-Bernardy 7 years ago.
widgets.diff (2.3 KB) - added by Denis-de-Bernardy 7 years ago.
placematt.png (19.3 KB) - added by Denis-de-Bernardy 7 years ago.
reason why placematt class should get dropped
4264.RTL.diff (1.0 KB) - added by Sewar 7 years ago.
RTL support

Download all attachments as: .zip

Change History (27)

Denis-de-Bernardy7 years ago

comment:1 Otto427 years ago

  • Version set to 2.1.3

Confirmed. Same issue exists with:
-Latest version of the Sidebar Widgets plugin, Wordpress 2.1.3, and IE7.
-Wordpress.com and IE7

Have not confirmed issue with widgets in 2.2 yet.

The "default sidebar" things seem to be centered on the page in IE7 for some reason.

comment:2 rob1n7 years ago

  • Version changed from 2.1.3 to 2.2

I'm pretty sure he means the integrated widgets in 2.2.

comment:3 Denis-de-Bernardy7 years ago

It's in the widgets plugin and the integrated widgets in WP 2.2 and (last I checked) the widgets used on wordpress.com.

This really is a blocker imho.

comment:4 rob1n7 years ago

It just looks different, right? Still functional?

comment:5 ryan7 years ago

I agree that it is ugly and needs to be fixed, but I don't think it is a blocker.

comment:6 rob1n7 years ago

I think this can be staved off for 2.2.1.

comment:7 rob1n7 years ago

  • Owner changed from anonymous to andy

comment:8 rob1n7 years ago

  • Milestone changed from 2.2 to 2.2.1

comment:9 intoxination7 years ago

There is more than just appearance, although minor. In IE7, the available widget drop zone won't expand past 2 rows of available widgets. That prevents you from dragging all the widgets back down to that area if you want (one you get your 2 rows, you can't add anymore - they just float back to the top).

Again - it is something that probably won't affect many people, but it is a functionality problem.

comment:10 technosailor7 years ago

I don't use IE so missed this, but I tend to agree that it needs to be fixed prior to 2.2 public download. I know we won't push 2.2 to our blogs until 2.2.1 if it is not addressed because we do use widgets ALOT and too many (for my liking) of our bloggers use IE.

comment:11 foolswisdom7 years ago

  • Summary changed from widgets very broken in IE to IE7, available widget drop zone won't expand past 2 rows of available widgets

comment:12 Denis-de-Bernardy7 years ago

  • Milestone changed from 2.2.1 to 2.2

Rob1n & Ryan: It's not functional. See comment by intoxination, 05/15/07 22:43:43. It's true annoyance for IE7 users as soon as they've more than a few plugins in the admin interface. If I recall correctly, they can no longer remove widgets past a certain point.

D.

comment:13 JeremyVisser7 years ago

  • Milestone changed from 2.2 to 2.2.1

2.2 released

Denis-de-Bernardy7 years ago

comment:15 Denis-de-Bernardy7 years ago

The attached patch makes things work as expected in FF2 and IE7. Can anyone with IE6 and other browsers give it some love?

D

comment:16 ryan7 years ago

The part of the patch that changes "placematt" to "placemat" didn't apply cleanly so I left it out. Seemed to behave well with IE6 running in wine on Ubuntu.

comment:17 ryan7 years ago

Forced it to expand to 3, 4, and then 5 rows of widgets. Looked good on IE6 and FF2/linux. Elements within the sidebars lined up properly.

comment:18 Denis-de-Bernardy7 years ago

actually, the part with the 'placematt' changed to 'placemat' does apply -- it could be cleaned up by dropping the placematt class entirely.

If it stays around, it's a big mess with themes with three columns (I'll attach a screenshot).

Denis-de-Bernardy7 years ago

reason why placematt class should get dropped

comment:19 ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5493]) Fix widget admin layout for IE7. Props Denis-de-Bernardy. fixes #4264 for 2.2

comment:20 ryan7 years ago

(In [5494]) Fix widget admin layout for IE7. Props Denis-de-Bernardy. fixes #4264 for 2.3

comment:21 ryan7 years ago

I put this live on wordpress.com for further testing and feedback. Looking good so far.

Sewar7 years ago

RTL support

comment:22 Sewar7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Let's fix RTL also.

comment:23 foolswisdom7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Sewar? A ticket with a released milestone? Please open a new ticket referencing this one.

Note: See TracTickets for help on using tickets.